'93 Ski-Doo cleaned carbs, now only get full throttle - Snowmobile World : Your #1 Snowmobile Forum

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-07-2010, 12:55 AM Thread Starter
Junior Member
 
Join Date: Jan 2010
Posts: 1
Unhappy '93 Ski-Doo cleaned carbs, now only get full throttle

Was not getting top end speed. When I would depress throttle all the way, the engine and sled would bog down, sometimes backfire and or sputter. Today I removed the carbs from the engine, but left all gas lines and cables in place. I removed the bottom of the carb and cleaned the "bowls" where the floats are. I did not completely disassemble the carbs. I cleaned them with a rag and some brake parts cleaner for lack of proper carb cleaner. After I reassembled the sled and started it up, it revved to max and I lost control of the sled and had to hit kill button to shut the sled down. Anyone have any idea what I did wrong and how to fix it? Thanks.
G-Nelly is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-07-2010, 05:38 AM
Junior Member
 
Join Date: Jan 2010
Location: Plymouth, MN
Posts: 17
did you check the idles on the carbs make sure they are all in sync and then make sure your low speed jet isnt blocked
pistonmelter is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome