98 Ski-doo 670 summit X eletical problems - Snowmobile World : Your #1 Snowmobile Forum

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-15-2010, 10:40 PM Thread Starter
Junior Member
 
Join Date: Jan 2008
Posts: 8
98 Ski-doo 670 summit X eletical problems

I have a 98 ski-doo 670 summit x. On the last ride of the season last year all the electronics in my dash went out and my head light and tail light. at the end of the ride I opened the hood and nothing seemed to be disconected. the electronics work at times for a couple seconds at random. Anyone got any ideas on what might be causing this? Thanks Chase
ski-doo boy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome