1996 600 XLT Carb problem - Snowmobile World : Your #1 Snowmobile Forum

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-26-2017, 12:13 AM Thread Starter
Junior Member
 
Join Date: Jan 2017
Posts: 1
1996 600 XLT Carb problem

Hello. I am brand new to the forum and I need some help. I bought a 1996 600 XLT SKS that was not running and would fill the crank case with gas . I owned one years ago and thought It would be a good starter sled for the family.Long story short, I have done a compression test and all 3 cylinders are around 110 psi. I have replaced the fuel pump, 2 cracked boots, and all spark plugs. I have got it to run on 2 out of 3 cylinders. I have cleaned the carb and jets but still will not run on that cylinder. I have swapped the carb around and the problem follows the carb.It just dumps gas out the exaust port. If I plug the vent line that runs up the handle bars It will fire. I have read a few threads that are similar but cant get any answers. Oh I did not swap the choke cables to see if that makes a difference.*Thanks for reading and any insight is appreciated.*
Cheers
CC
HurtinAlbertan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome