2004 Polaris widetrax lx - Snowmobile World : Your #1 Snowmobile Forum

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-26-2017, 08:29 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Posts: 1
2004 Polaris widetrax lx transmission question

Noob needing guidance.

Just got a new to me used sled. It runs strong however, I am seeing transmission fluid leaking out underneath. I have looked (as far as I can se) and I do not see any cracks or fluid on the case. Is this a common issue with high mileage sleds? Also, if it is a seal do I have to pull the engine to get at it? Or just the break assembly? The service manual doesn't specify this tidbit. Currently, I am keeping a close eye on the oil level. I use the sled to get into my property. Its about a 5 mile ride. TIA
Boaron.

Last edited by boaron; 01-26-2017 at 08:35 PM.
boaron is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome