problems with 1991 550 ext special - Snowmobile World : Your #1 Snowmobile Forum
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-13-2010, 12:28 PM Thread Starter
Junior Member
Join Date: Jan 2010
Posts: 2
problems with 1991 550 ext special

sled ran for a half mile strech then i turned around and it stopped running, but i could get it back running but it would not go any where it would only get up to 2000 rpm. then i let it sit for about an hour and went and started it up and it drove fine except when it first started out i had to feather the gas alittle before it got going good. then i parked the sled and it will not start it was left over night then it started up with one pull. then i ran it for a little bit at 8-9000 rpm and it "dogged" out and quit running.
miller_93 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome