97 700 sks Bogging, Then screaming - Snowmobile World : Your #1 Snowmobile Forum
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-05-2010, 09:49 AM Thread Starter
Join Date: Dec 2006
Posts: 37
97 700 sks Bogging, Then screaming

Took the 97 700 Sks out for it's first ride of the season at Jones Pass. It was running ruff at the start. Then when I got up to open areas it would scream then bog. It was in and out all day. No power at times then it would have spurts of full power. This was starting to happen at the end of the season last year. Looking for suggestions. Fuel filter? Fuel Pump? Thanks All for any help

Last edited by Colorado700; 01-05-2010 at 09:50 AM. Reason: missspelled word
Colorado700 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-05-2010, 11:59 AM
Join Date: Dec 2009
Location: barrie
Posts: 32
check carbs are clean and also set in sync
callow52 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome