No Spark - Snowmobile World : Your #1 Snowmobile Forum

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 12-04-2004, 09:16 PM Thread Starter
Senior Member
 
Gabby's Avatar
 
Join Date: Oct 2003
Posts: 142
OK guys I have some questions for a friends sled we are working on. It is a 2001 MxZ 800 X with DPM. It does not have any spark what so ever. Can someone throw me some ideas on what to check? The DESS is plugged in and the kill switch is out. Could it be the MPEM? Or maybe the coil, trigger coil or stator? Maybe something with this DPM thingy? What have you guys seen before? Are there any known problems? Thanks.

2011 Ski Doo MxZ X-RS 800 ETEC
2009 Ski Doo MxZ-X 800R
2006 Ski Doo MxZ Renegade X 1000 SDI
2002 Ski Doo MxZ 800 Sport w/ 144 gold digger studs.
2002 Ski Doo MxZ 500 R Sport w/ 96 gold digger studs & electric start.
Gabby is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-05-2004, 01:10 AM
Administrator_X
 
idooski's Avatar
 
Join Date: Mar 2001
Location: SW Michigan!!
Posts: 5,122
Quote:
Originally posted by Gabby@Dec 4 2004, 09:38 PM
OK guys I have some questions for a friends sled we are working on. It is a 2001 MxZ 800 X with DPM. It does not have any spark what so ever. Can someone throw me some ideas on what to check? The DESS is plugged in and the kill switch is out. Could it be the MPEM? Or maybe the coil, trigger coil or stator? Maybe something with this DPM thingy? What have you guys seen before? Are there any known problems? Thanks.
[snapback]371252[/snapback]
First check the obvious - look for any unplugged terminals or worn looking areas in the harness where a wire could be broken. There have been some problems in the harness near the connections at the voltage regulator. (right front of engine, attached to the chassis. There have also been some problems with the stator wires getting rubbed bare where they exit the case. I had a short in the wires that lead from the stator to the MPEM on my 02. Next, I would check the stator, then the coil. It would still spark if the DESS is unplugged, it just won't run at a high enough RPM to move. The DPM can cause problems, but it has nothing to do with spark. You can unplug the kill switch to eliminate that, but remember to reconnect right away.

Hope this helps some.

Keith
idooski is offline  
post #3 of 8 (permalink) Old 12-05-2004, 09:01 AM
Senior Member
 
SDRENE800RER's Avatar
 
Join Date: Jan 2003
Location: Epping, New Hampshire USA
Posts: 751
This is a long shot, but it happened to my bother inlaws sled.

He unplugs his electric sheild at his helmet instead of at the sled like the rest of us do. This allows the cord to dangle down to where the male plug end can make contact with the tunnel and short out. He has done this a bunch of times. The sled wont start if the plug makes contact to anything metal. It will also shut the sled down on the trail when he forgets to connect it to his helmet, fires up and takes off, then it grounds and stalls the sled.



This is a more common issue to check. Make sure you have no corrosion or powdery oxidation residue inside the sparkplug caps. this happens just from setting over time. It becomes more of a problems if the caps arent sealing out air due to age or minor cracking.


02 Renegade 800 RER/DPM* HPS Can* V-Force3 Reeds* RKT Head/Piston/Shim Kit w/Intake Mods* No Money Left on Account* =P

Sleddin' when cold!
Jeepin' when warm!

Is it cold enough yet?

Totally Kick Butt New Jeep Site..........Jeep Horizons.com
SDRENE800RER is offline  
post #4 of 8 (permalink) Old 12-05-2004, 01:35 PM
Member
 
Join Date: Mar 2004
Location: Rochester NY
Posts: 52
my kill switch went bad. I checked and re-checked all of teh circuitry per the doo service manual and felt dumb when I took it to the dealership and that's all it was. Can't complain about the $4 part cost to fix it though.

If you don't have teh doo manual with voltage, resistance values, take it to the delearship or buy the CD manual on eBay for $10.
feldme is offline  
post #5 of 8 (permalink) Old 12-05-2004, 06:27 PM Thread Starter
Senior Member
 
Gabby's Avatar
 
Join Date: Oct 2003
Posts: 142
I do have the CD service manual for my 2002. This sled is a 2001 put I followed the troubleshooting section for resistance and voltage checks a the MPEM is bad. There is suppose to be 25 - 100 volts to the high voltage coil and we only got 4volts. I know you are not suppose to switch MPEMs between sleds but we had the exact same sled there (even the same color) and we checked that on and it had 100 volts so we quick swapped it just to check spark. We got spark with the other one. how much is a new MPEM going to cost this guy? It sucks cause he don't have a bunch of money. Also this is a dealer item I am sure cause it has to be programmed correct?

2011 Ski Doo MxZ X-RS 800 ETEC
2009 Ski Doo MxZ-X 800R
2006 Ski Doo MxZ Renegade X 1000 SDI
2002 Ski Doo MxZ 800 Sport w/ 144 gold digger studs.
2002 Ski Doo MxZ 500 R Sport w/ 96 gold digger studs & electric start.
Gabby is offline  
post #6 of 8 (permalink) Old 12-05-2004, 07:45 PM
Senior Member
 
snowhack's Avatar
 
Join Date: Nov 2004
Location: Western New York
Posts: 239
Send a message via Yahoo to snowhack
Arrow

I had a similar "no spark" issue and it turned out to be the stator, but in your case you got the proof its the MPEM. In my travels I priced one through Pioneer Performance , also a Ski-doo dealer, and they said $252.00. Ya sorry.....

ride hard or lock-in....

'00 Mxz 700 Adrenaline
'01 Mxz 500 Trail
'94 Formula Z 583
snowhack is offline  
post #7 of 8 (permalink) Old 12-07-2004, 12:48 AM
Administrator_X
 
idooski's Avatar
 
Join Date: Mar 2001
Location: SW Michigan!!
Posts: 5,122
I have a new MPEM w/tether for a 2001 800 laying around here, but it is for a non DPM sled.
idooski is offline  
post #8 of 8 (permalink) Old 12-07-2004, 10:05 AM Thread Starter
Senior Member
 
Gabby's Avatar
 
Join Date: Oct 2003
Posts: 142
Hey idooski thanks. That would not work as this is an 800 X with DPM. Actually we found out that the X and Adrenaline MPEM is $350 vs. the $250 for a standard one :bash:

2011 Ski Doo MxZ X-RS 800 ETEC
2009 Ski Doo MxZ-X 800R
2006 Ski Doo MxZ Renegade X 1000 SDI
2002 Ski Doo MxZ 800 Sport w/ 144 gold digger studs.
2002 Ski Doo MxZ 500 R Sport w/ 96 gold digger studs & electric start.
Gabby is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome