1989 Safari 377 - Snowmobile World : Your #1 Snowmobile Forum
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-20-2007, 07:04 PM Thread Starter
Junior Member
Join Date: Dec 2007
Posts: 2

The 1989 Safari 377 have a constant problem of fouling plug on #1 Cyl ( clutch side). Friend told me that it is probably the the crank seal causing this prob. I got the carb rebuild and rejetted etc. Runs smotther without cracking sound finally. The last issue is: spark plug. Wow, The fan side spark plug is a lovely brownish coulour as for the clutch side, black and cold. My solution while finding a solution is changing spark plug #1 to #2 cyl vice versa.
I tried running mix fuel ratio 60:1 no changes ( removed the oil jet pump and plugged both oild supply line).

Any suggestion from experience snowmobile maintainer. Perhaps a link on how to replaced crankshaft seal..etc.

Help will be greatly appreciated


Safari owner
osylazz is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome