1993 Yamaha Phazer 2 - Snowmobile World : Your #1 Snowmobile Forum

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 01-19-2009, 11:13 AM Thread Starter
Junior Member
 
Join Date: Jan 2009
Posts: 2
1993 Yamaha Phazer 2

Can someone share some info? Picked up this cheap sled for fishing that sat for 6 years. I did the carbs and it runs pretty good however I noticed when I switch the hand warmers on it does not want to rev. out and sounds like it's misfiring. Also when it warms up it does the samething without the warmers on but not al the time. Any ideas?
stevebo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-20-2009, 05:13 PM
Senior Member
 
retiredpop's Avatar
 
Join Date: May 2001
Location: Calgary,Alberta
Posts: 686
That is strange because the lighting circuit is different from the ignition circuit. They have different coils in the stator. It may be the stator going bad or a bad ground connection somewhere.

The older I get the better I was; In fact now that I think about it I am a legend.
retiredpop is offline  
post #3 of 3 (permalink) Old 01-20-2009, 07:55 PM Thread Starter
Junior Member
 
Join Date: Jan 2009
Posts: 2
1993 Yamaha Phazer 2

Thanks for the reply. I think I've figured it out. Connectors on the wires coming out of the motor could have been a little loose. Check each one and seems to be alright when I ran it in the backyard. Tomorrow I'll take it for a good run. Fingers crossed.
stevebo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome