Exciter 570 ( 1989 ) Carb set up / jetting ??? - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-06-2009, 01:47 PM Thread Starter
Senior Member
 
Lasse's Avatar
 
Join Date: Mar 2001
Location: SWEDEN
Posts: 431
Question Exciter 570 ( 1989 ) Carb set up / jetting ???

Hi

I need some advice on how to set up the carbs on a Exciter 570 ( 1989 ) for a friends sled.
I have read in many forum that the OEM jetting is a big joke & only BS and sucks big time |

What jetting should I be putting in them ?
I'm really lost here.

The sled is 100 % stock and has the Mikuni VM-38 with the heated carbs and so on,
except that the oil injection is deleted and the sled are running pre mixed gas.

Riding height : 250 m <--> 800 m ( 820 feet <--> 2650 feet )

Present carb set up :
* ? PowerJet ? : 200
* Main jet : 350
* Pilot jet : 42,5
* Needle : 6FL68
* Needle jet : 480 P6
* Air screw : 0,5 turn out



.

// Lasse from SWEDEN.



Lasse is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-08-2009, 05:15 AM Thread Starter
Senior Member
 
Lasse's Avatar
 
Join Date: Mar 2001
Location: SWEDEN
Posts: 431
Question

^^^ ttt ^^^


HELP !!!


.

// Lasse from SWEDEN.



Lasse is offline  
post #3 of 5 (permalink) Old 10-23-2012, 06:00 PM
Junior Member
 
Join Date: Oct 2012
Location: Wisconsin
Posts: 2
So that's what them plug's connected to the bottom side of the carb's are... I had no clue and could not find any information on them..
Do I really need them operating ?
Jambolias is offline  
post #4 of 5 (permalink) Old 10-25-2012, 06:15 PM
Member
 
Join Date: Jan 2006
Location: Muskoka
Posts: 68
I had 1 of those. I stayed to the factory jets. The problem with that sled is it may over heat and bog with no power. To fix it I pulled out the thermostat and cut the guts out of it and put the remainder back in ( the spring and moving parts ). Disconnected the tors ( plug the wires in to each other on the harness to complete the curcit). Mine ran great after that. Hope this helps.
mmsrx is offline  
post #5 of 5 (permalink) Old 10-25-2012, 06:18 PM
Member
 
Join Date: Jan 2006
Location: Muskoka
Posts: 68
Also I never ran the sled with the carb warmers on.
mmsrx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome