2005 Rs Venture Stator burnt - Snowmobile World : Your #1 Snowmobile Forum
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-23-2010, 09:12 PM Thread Starter
Junior Member
Join Date: Feb 2010
Posts: 3
2005 Rs Venture Stator burnt

Just thought I would post an issue I have encountered, my venture stator has bit the dust after approx. 8500Km. Issue started when machine would not start at a regular trail stop. It had a dead battery issue, I replaced battery at camp and check charging voltage found to be nil just battery voltage. After returning home I performed a few more test and came to the conclusion the stator was not charging. I was able to remove stator without removing engine but it was very difficult. I am currently awaiting parts to see if it will go back in the way it came out. Stator wires were burnt where they attatch to the coils around back of stator.
Yami217 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome