flipped my sled need help asap - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 01-14-2012, 01:19 AM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 18
Exclamation flipped my sled need help asap

yesterday i was out riding and i flipped my sled. now when i start my sled it starts first pull but as soon as u give it gas it boggs out and wont move. i believe the engine just isnt creating enough power to engage the clutch. also when i flipped my coolant cap poped off and coolant went EVERYWERE... so if anyone has any suggestins as to what the problen could be please help

Last edited by jklap42029; 01-14-2012 at 02:21 AM.
jklap42029 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-14-2012, 01:14 PM
Junior Member
 
Join Date: Jan 2012
Location: Belding,MI
Posts: 11
If it idles good, sounds like something is bent, Is the track location good?
rbannen is offline  
post #3 of 6 (permalink) Old 01-14-2012, 03:16 PM
Senior Member
 
Join Date: Feb 2010
Location: thunder bay ontario
Posts: 556
If it's not creating enough power to engage the clutch, it may be just running on one cyld.
mmgg is offline  
post #4 of 6 (permalink) Old 01-14-2012, 03:27 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 18
going to check the compression now ilm post later if thats the issue
jklap42029 is offline  
post #5 of 6 (permalink) Old 01-16-2012, 01:54 PM
oldslowsledder
 
CORY9's Avatar
 
Join Date: Mar 2003
Location: Parry Sound,Ontario
Posts: 6,491
did your belt get covered in coolant? Perhaps it's slipping.

2010 GSX
Wife 08 Vector
Son 2012 Nytro XTX
CORY9 is offline  
post #6 of 6 (permalink) Old 01-16-2012, 05:13 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 18
found the issue.... the guy that owned the sled before me must have not torqued the bolts on the head... they were ao loose i could twist them by hand and there was coolant bubbling out of one of the bolts... need new headgasket not getting enough compression
jklap42029 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome