1994 EXT 580 EFI help [Archive] - Snowmobile World : Your #1 Snowmobile Forum

: 1994 EXT 580 EFI help


arcticcatnewbie
02-23-2009, 08:19 PM
Hi,

I just traded a Skidoo Mach 1 583 for a 1994 EXT 580 EFI. The Arctic Cat is a nice sled and fast when it runs. But I can not get it to idle and now it just started to bog at high speeds I will hit about 75mph and it will stall right out or bog down to 2-5 RPM then it will go back up and do same thing over again. Any help would be apreciated.


Thanks Ryan

BT53
02-23-2009, 09:12 PM
I posted this advice to another person having similar problems:

There is a throttle safety switch built inside the handlebar housing that the throttle lever mounts to (the one that also has the kill switch mounted on top). If the switch inside the housing goes bad, you will have the symptoms you describe. Bypass the switch with the bypass tool that came in the tool kit to verify this.

Don't jury rig it! The switch keeps the sled from running away from you if the carb slides get iced up or the cable gets sticky.

arcticcatnewbie
02-24-2009, 05:55 AM
If I dont have the bypass tool how else can I bypass it ?

Tschmoodz13
02-24-2009, 08:17 PM
Hi, I have your exact sled '94 EXT EFI, Ive owned it for about 2 years now and have had many problems with it. It sometimes completely fouls/floods out and wont start for a long time. I was just about to post a thread like this. Does yours do this also? When I do get the thing started it runs very well. Ive gone 90+ with it on the trails. I always make sure that the battery is fully charged, b/c the EFI runs off the battery.

TJ

catlover600
02-24-2009, 08:23 PM
i had that problem were it wouldnt idle at all it would just stall out on my 2000 zr and instead of getting a bypass kit or a new switch i folllowed the wires out and put a tether on it disabled the throttle switch and the kill switch but thats what a key is for. im not sure if it will disconnect both for yours as well but my philosophy is that if it where to stick open you could just turn it off and if you fell off the tether would kill the motor. its an easy fix if you dont the cob job but it works

arcticcatnewbie
02-24-2009, 08:28 PM
Hey I fixed my problem then ran into anther one. I looked at my 3 prong plug and cut the yellow cable with black stripes. that disabled my throtle safty sensor. it sat there ran great Idle fine, But now it wont start. Any Info would be great I also adjusted a little screw on top of my throtle bodys looked like a idle screw. Possible I flooded my crank it spuders then back fires or I might have been thinking crank seals.

trav177
03-08-2010, 02:29 PM
my 97 580 efi was doing same thing i replaced stator and it ran the best it ever did since i owned it. i hit the throddle and skis did not hit ground untill i hit 100 mph it was awsome. used stators i was told not to use. new cat stator is 600$ but new stator from rmstator 199$

ttereve
03-08-2010, 10:11 PM
hey trav177 I have a post on here about a 580 ext efi ..mine ran great then it just died no spark.. I did an ohm's test on the stator but did not physicaly look at it..do you think maybe it could be my problem as well

ttereve
03-08-2010, 10:17 PM
arctccatnewbie ..I know there is a tpi on the fuel rail you have to wot then let it snap back to let the ecu reset the tpi. try that .. if you feel you flooded it remove your exhaust and clear it .. try starting it without exhaust but dont let it run very long it needs the back pressure.

trav177
03-08-2010, 10:48 PM
hey trav177 I have a post on here about a 580 ext efi ..mine ran great then it just died no spark.. I did an ohm's test on the stator but did not physicaly look at it..do you think maybe it could be my problem as well

dont think looking at it matters my old one looked the the same as my new one but not as clean. if your ohm test was allright i would have to say you have an other problem.

rudawski
03-09-2010, 12:16 AM
Hmmm....skis didn't touch till 100mph. Interesting. My 97 580 won't quite go that fast. Must be the EFI right? Truthfully, my speedometer will read that fast, but only when I'm spinning the track like a complete A$$. You may be helpful, but you're a terrible liar!