Snowmobile World : Your #1 Snowmobile Forum - View Profile: admin

admin admin is offline

Administrator

  Visitor Messages

Showing Visitor Messages 1 to 10 of 15
  1. falconeddie
    01-31-2016 07:29 PM - permalink
    falconeddie
    i have 1995 polaris xrc440 oil is running real rich one hole tank of oil 3/4 tank of gas is there an ajust on oiler and were
  2. NewfieCat
    01-02-2016 09:16 AM - permalink
    NewfieCat
    Hi, new member. But cant post...whats up with that? seeking advice on headlight outage.
  3. Superpatch
    12-18-2013 08:31 PM - permalink
    Superpatch
    So this is good... send me here with no answers to ppl w/same question as me... HELPFULL! :O ....CAN'T POST!!!
  4. ArcticJag
    12-02-2013 12:09 AM - permalink
    ArcticJag
    Am back.
    Been out sledding today breaking in the new sled. Too cold to go to far. Hope to have a great season this year .
    My new sled is 1999 500 triple polaris indy xlt le
    Loving it so far.
  5. Kevint
    12-01-2013 08:39 PM - permalink
    Kevint
    I created a posting but it did not appear. So I created it again and quickly noticed that it must be approved. It flashed so fast that I did not know that it had to be approved. Can you please delete my second posting? Thanks
  6. XCSP
    06-30-2013 08:06 PM - permalink
    XCSP
    ADMIN: I HAVE RECEIVED 100 OF THESE SPAM EMAILS FROM YOUR SITE. PLEASE STOP SENDING THESE IMMEDIATELY AND DELETE MY ACCOUNT ASAP!!!!!!!!!!!! USER: XCSP
    Hello, XCSP!
    We've noticed that you've not been active on Snowmobile World : Your #1 Snowmobile Forum for quite some time now, and we miss you! Could we not tempt you back?
  7. dokis
    11-28-2012 01:56 PM - permalink
    dokis
    why cant i post anything in the general questions forum or w.e???????????????
  8. YamaDan
    03-01-2012 08:51 AM - permalink
    YamaDan
    Sold my sled years ago. Please cancel my subscription and stop sending e-mails.

    Thx.
  9. dmohr
    02-10-2012 07:13 PM - permalink
    dmohr
    hey, i just joined this forum and i am not able to post anything. Please help, thanks.
  10. LRunestad
    02-03-2012 02:16 PM - permalink
    LRunestad
    I would like to be able to post a thread (message) on this site but apparently do not yet have permission. Please advise how to go about doing this. Thanks.

  About Me

  • About admin
    Disable Sidebar in Forum view
    Enable
    Where I Sled
    Constance Bay - use to
    Primary Sled
    Rupp American
    Year Started Sledding
    1974

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 02-10-2016 11:23 AM
  • Join Date: 02-13-2008
  • Referrals: 2

  Mentions

No results to display...

  Quotes

No results to display...
 
For the best viewing experience please update your browser to Google Chrome