Snowmobile World : Your #1 Snowmobile Forum - View Profile: puree

puree puree is offline

Senior Member

  Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. puree
    12-18-2013 08:49 AM - permalink
    puree
    I would guess that you are sucking air,,, I believe you said you already replaced your boots that are between your carb and motor,,,, does the sled have the air box on it and in good shape?? Have you pulled and cleaned the carbs?? worst case scenerio is you have a main seal out and are sucking air right through the bottom end. you also could have an issue with your throttle cable to short, pinched, or simply not set up right. You havent happened to add a set of risers to the sled recently have you?? that would stretch the throttle cable and cause issues.
    one last place (I am assuming that you have dual carbs), but your thottle cable goes to a little black splitter box,,, one cable comes in and two go out (one to each carb), I have seen those fail and either give you a high idle or nothing at all. so we have quite a bit to look into,,,, let me know what you have done, what you havent done (off of what I have mentioned), and we will see if we cant get you taken care of.
  2. mxzzx
    12-09-2013 10:47 PM - permalink
    mxzzx
    cant get my 2001 mxz to idle down,,,,idles at 3000 rpm,,,help please ,,,

  About Me

  • About puree
    Location
    Northwest Ohio
    Interests
    Love to ride sleds (why else would I live here??)
    Occupation
    Crop Consultant
    Mileage
    2550
    Disable Sidebar in Forum view
    Disable
    Where I Sled
    Newberry, Grayling, Home, anywhere there is snow
    Primary Sled
    2009 Renegade 1200
    Year Started Sledding
    1978
  • Signature
    09 1200 Renegade
    10 1200X Renegade
    03 F7
    07 F6lxr
    03 Z370es
    78 Invader 440


  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 03-22-2015 02:05 AM
  • Join Date: 02-24-2003
  • Referrals: 0

  Contact Info

Instant Messaging
Send an Instant Message to puree Using...
This Page
http://www.snowmobileworld.com/forums/members/6862-puree.html

  Mentions

No results to display...

  Quotes

No results to display...
 
For the best viewing experience please update your browser to Google Chrome