Stator Corp? - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > ARCTIC CAT

Reply
 
Thread Tools
Old 01-13-2003, 03:00 PM   #1
versatileman
Senior Member
 
versatileman's Avatar
 
Join Date: Jan 2003
Location: S.W. Lower MI
Mileage: 2,950 miles
Primary Sled: 2002 ZR600
Where I sled: All of Michigan
Posts: 980
Default

Well I finaly broke down and brought my 99 ZR 600 EFI to the dealer this morning.
Last spring it was exibiting all the signs of a stator going bad.
Finally on the last ride of the season it died for good - stator was cooked.
A/C wanted $600.00 for a part that, to this day, I feel should have been replaced free of charge (or maybe labor only) but they basically told me that since I was not the original purchaser of the sled (I bought it with 400 miles) that I was SOL.
I had Stator Corp rewind the stator for my sled and one for a friends 580EFI (one of the coils actually fell out of the stator frame on his original stator).- nice manufacturing eh?
Finally got some snow here in Michigan and got to put on a few miles - the sled ran good for the first 50 or 60 miles but now acts very simillar to the way it did when the stator failed the first time. The 580 only ran about 35 miles before it completely died.
My dealer said they have replaced 5 or 6 stators this season on sleds that had stators rewound at a place called "Stator Corp". Most of the rewound units had less than 100 miles on them.

Any one have good or bad luck with Stator corp?

I have been a loyal green fan for the past 15 years - but I am seriously considering changing my brand loyalty.
I have never had such poor support from a manufacturer.
Actually had an A/C rep tell me "it sucks to be you" when I contacted them about the first stator.

I am seriously considering a 5 gallon bucket of gas and a road flare to finally solve my ZR woes.

???
__________________
Loud pipes close trails!

Current rides:
2002 ZR600
1998 ZL500
1997 SX700
Past rides:
1995 T-cat (soon to be asphalt racer)
1997 Z440
1999 ZR 600
2001 ZL 800
1996 Z440
1994 ZR700
1981 Panther 440

CR125,250, Quad sport, Buell S3T, LiVe WiRe electric FZR, 4 JS550's, JS750, Cheyenne inboard ski boat, 1996 Sea-Doo XP800, 2000 Silverado, 69 Dodge Travco, and a partridge in a pear tree
versatileman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-13-2003, 07:50 PM   #2
elk
Junior Member
 
Join Date: Mar 2002
Location: rathdrum, idaho
Where I sled: North Idaho
Posts: 7
Default

Hunred miles and no problems so far on a stator corp rewind.
__________________
2001 Mountain cat 800
1998 Powder Special 600 efi
1995 Cougar Moountain Cat 550
elk is offline   Reply With Quote
Old 01-13-2003, 07:54 PM   #3
elk
Junior Member
 
Join Date: Mar 2002
Location: rathdrum, idaho
Where I sled: North Idaho
Posts: 7
Default

Actually I take that back after picking up from repair shop it started back firring and missing like before and no power. I took it back and we replaced the kill switch and it runs like a top. My theory is the kill switch goes bad and ends up burning up the stator. I had a buddy the same thing happened he had the stator replaced at the dealer (600 bones) and 5 miles into the ride started acting up and the same thing the kill switch went bad.
__________________
2001 Mountain cat 800
1998 Powder Special 600 efi
1995 Cougar Moountain Cat 550
elk is offline   Reply With Quote
Old 01-14-2003, 12:21 AM   #4
versatileman
Senior Member
 
versatileman's Avatar
 
Join Date: Jan 2003
Location: S.W. Lower MI
Mileage: 2,950 miles
Primary Sled: 2002 ZR600
Where I sled: All of Michigan
Posts: 980
Default

Ya, kills have been disconnected since 1,000 mile mark or so.
Truely hope it is something stupid that I overlooked.

Any one have hundreds or thousands of miles on a rewind?


__________________
Loud pipes close trails!

Current rides:
2002 ZR600
1998 ZL500
1997 SX700
Past rides:
1995 T-cat (soon to be asphalt racer)
1997 Z440
1999 ZR 600
2001 ZL 800
1996 Z440
1994 ZR700
1981 Panther 440

CR125,250, Quad sport, Buell S3T, LiVe WiRe electric FZR, 4 JS550's, JS750, Cheyenne inboard ski boat, 1996 Sea-Doo XP800, 2000 Silverado, 69 Dodge Travco, and a partridge in a pear tree
versatileman is offline   Reply With Quote
Old 01-15-2003, 04:36 PM   #5
wrencher
Junior Member
 
Join Date: Nov 2002
Location: Beautiful state of Maine
Where I sled: maine
Posts: 29
Default

I have had more than 10 stators rewound by Stato Corp. both for Polaris atvs and Arctic Cat sleds. Never had one back yet. Some have been out there for a couple of years You might have another problem.
wrencher is offline   Reply With Quote
Old 01-15-2003, 04:46 PM   #6
versatileman
Senior Member
 
versatileman's Avatar
 
Join Date: Jan 2003
Location: S.W. Lower MI
Mileage: 2,950 miles
Primary Sled: 2002 ZR600
Where I sled: All of Michigan
Posts: 980
Default

Thanks for the replies,
I'll post the fix after it has been repaired.
__________________
Loud pipes close trails!

Current rides:
2002 ZR600
1998 ZL500
1997 SX700
Past rides:
1995 T-cat (soon to be asphalt racer)
1997 Z440
1999 ZR 600
2001 ZL 800
1996 Z440
1994 ZR700
1981 Panther 440

CR125,250, Quad sport, Buell S3T, LiVe WiRe electric FZR, 4 JS550's, JS750, Cheyenne inboard ski boat, 1996 Sea-Doo XP800, 2000 Silverado, 69 Dodge Travco, and a partridge in a pear tree
versatileman is offline   Reply With Quote
Old 01-16-2003, 01:31 PM   #7
1fastcat800
Senior Member
 
1fastcat800's Avatar
 
Join Date: Jan 2003
Location: Mpls, MN
Primary Sled: 2006 Crossfire 700
Where I sled: Minnesota, Wisconson, the U.P.
Posts: 120
Default

Stator Rewinders

Electric Tech. – 508-478-0692…….$125……Lifetime warranty
Stator Corp. – 508-478-0976……….$150……2 year warranty
Ricky’s Stator – 619-449-3905……..$150……warranty?

I have used Elect Tech about 6 times. I had one go bad and they turned the warranty around in less than a week. Told me they had some bad wire. Very quick turn around from these guys using priority mail for about $6.00.
__________________
Dave ..... 763-449-9472
www.shock-service.com
1fastcat800 is offline   Reply With Quote
Old 01-16-2003, 05:16 PM   #8
versatileman
Senior Member
 
versatileman's Avatar
 
Join Date: Jan 2003
Location: S.W. Lower MI
Mileage: 2,950 miles
Primary Sled: 2002 ZR600
Where I sled: All of Michigan
Posts: 980
Default

Well, just heard from my dealer, both sleds have bad stators.
Contacted stator corp and they apologized up and down - it was a mistake on their end and are willing to correct them at no charge.
they said alot of their EFI stators from this fall failed within 30 or 40 miles.
I guess I don't care - I am ordering a new stator from A/C and having the old stator rewound again.
This way I can throw a spare in the trunk (many of my rides are 600mi+) so when it fails next time (and it will), I'm not down for a week during rideable snow.
I'm pretty sure my next sled will be a Ski-doo.
I have gone from loving my A/C to hating the damn thing (3 stator in three years)
A/C has let me down for the last time - If my sled was a car I would recieve a letter a month asking me to bring it in for repairs before it fails.
A/C said "it sucks to be you".

Nice, real nice...


__________________
Loud pipes close trails!

Current rides:
2002 ZR600
1998 ZL500
1997 SX700
Past rides:
1995 T-cat (soon to be asphalt racer)
1997 Z440
1999 ZR 600
2001 ZL 800
1996 Z440
1994 ZR700
1981 Panther 440

CR125,250, Quad sport, Buell S3T, LiVe WiRe electric FZR, 4 JS550's, JS750, Cheyenne inboard ski boat, 1996 Sea-Doo XP800, 2000 Silverado, 69 Dodge Travco, and a partridge in a pear tree
versatileman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:50 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.