1997 Formula 583 Bogging Bad! - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > SKI-DOO

Reply
 
Thread Tools
Old 12-14-2003, 01:50 PM   #1
spinner
Senior Member
 
Join Date: Nov 2003
Where I sled: ny
Posts: 219
Default

it starts and idles fine, but mid range and full throttle it bogs down enough that it will almost stall.... the other thing is one spark plug is burning ok, but the other one is running lean??? it also sounds bad too, maybe like it's only running on one cylinder????? any help would be great!
spinner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-14-2003, 02:59 PM   #2
lvrotax
Junior Member
 
Join Date: Nov 2003
Location: South central Ontario
Where I sled: Northumberland or Parry Sound
Posts: 26
Default

If this is the first run, one of your carb's are a good place to look. Could be ice in your line(ad isopropyl gasline antifreeze) or your carb(s) could be gummed from sitting all summer;(clean em use compressed air). I'm sure you've already put new plugs in her, with no improvement, but try switching plug caps and see if the problem moves to the other cylinder. They just thread off the wire. Just a few ideas. Good luck!

lvrotax is offline   Reply With Quote
Old 12-14-2003, 04:08 PM   #3
M-10
Member
 
M-10's Avatar
 
Join Date: Oct 2003
Primary Sled: 1998 MXZ-583 WITH M=10 REAR SKID
Where I sled: MINESOTA.
Posts: 65
Default

Also check the carb mounting boots for cracks or leaks due to loose hardware etc. But as posted above start at the carbs.
__________________
SKI-DOO RULZ
M-10 is offline   Reply With Quote
Old 12-14-2003, 04:34 PM   #4
sagebrush
Senior Member
 
sagebrush's Avatar
 
Join Date: Nov 2003
Primary Sled: 500 everest
Where I sled: Kamloops B.C
Posts: 168
Default

Ivrotax has the right ideal, clean them carb's. It sound like a air fuel mixture problem. My 670 had the same problem at the beginning of this season. After I cleaned the carb's, it had the throttle bog off idle. The factory setting said 2-2.5 turns out on the mixture screws, but it still bogged. I had the machine warmed up and turned both mixture screws back in a 1/4 turn at a time until the bog went away. I found it runs best at 1 3/4 turns out.
__________________
There's a fine line between, enthusiast and junky!
sagebrush is offline   Reply With Quote
Old 12-15-2003, 12:01 AM   #5
spinner
Senior Member
 
Join Date: Nov 2003
Where I sled: ny
Posts: 219
Default

when you say mixture screw, do you mean the idle air mixture? we'll check the plugs and wires also, thanks!
spinner is offline   Reply With Quote
Old 12-15-2003, 01:29 AM   #6
sagebrush
Senior Member
 
sagebrush's Avatar
 
Join Date: Nov 2003
Primary Sled: 500 everest
Where I sled: Kamloops B.C
Posts: 168
Default

No, not the idle adjusters, the air mixture screws. They are the the small brass screws, that are on the opposite side of the carbs from the idle adjusters. They have a small, slotted head on them, unlike the idle screws that take a phillips screw driver or your fingers to adjust them.
__________________
There's a fine line between, enthusiast and junky!
sagebrush is offline   Reply With Quote
Old 12-16-2003, 12:49 AM   #7
spinner
Senior Member
 
Join Date: Nov 2003
Where I sled: ny
Posts: 219
Default

fixed it, thanks! one main jet was clogged solid the other was half plugged and the needle was gunked up.... :thumbsup: runs great now!
spinner is offline   Reply With Quote
Old 12-16-2003, 11:39 AM   #8
sagebrush
Senior Member
 
sagebrush's Avatar
 
Join Date: Nov 2003
Primary Sled: 500 everest
Where I sled: Kamloops B.C
Posts: 168
Default

Glad you found the problem.

__________________
There's a fine line between, enthusiast and junky!
sagebrush is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:58 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.