Phazer Top Speed - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > YAMAHA

Reply
 
Thread Tools
Old 02-07-2006, 01:22 PM   #1
red97lt1
Junior Member
 
Join Date: Feb 2004
Primary Sled: 1987 Yamaha Phazer
Where I sled: Wisconsin/U.P. Michigan
Posts: 6
Default

I have a 87' Phazer 485cc, i COULD ONLY GET IT TO GO 70 MPH, i know it should be faster the carbs are clean and compression is good . It is running rich though what can i adjust to get better top speed???????????

Also when on pwder and jumping on the throttle the track starts making noises like thumping clicks and something is skipping ?
red97lt1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-07-2006, 01:27 PM   #2
akrievins
Senior Member
 
akrievins's Avatar
 
Join Date: Feb 2005
Location: Mississauga, Ontario
Mileage: 75 kms
Primary Sled: 2003 Yamaha SXViper
Where I sled: Rosseau + Parry Sound, Ontario.
Posts: 586
Send a message via MSN to akrievins
Default

Hey, you're not too far off, but it should have more go than that. I get my 91 Phazer II to 130kms/hr (80 mph) easy. As for adjusting, I'm sure someone on here will know what to do. I haven't had to touch any settings like that yet. I put new plugs in though.
What were you riding on? If you ride in deep powder, you're not gonna go very fast at all. You need good hardpack to get up there in the speed.
__________________
When Hell freezes over... I'll snowmobile there too!
-----------------------------------------------------------------------
2003 Yamaha SX Viper. 700 Triple

http://i48.photobucket.com/albums/f2...gniturepic.jpg
akrievins is offline   Reply With Quote
Old 02-07-2006, 03:22 PM   #3
materman
Member
 
Join Date: Nov 2005
Mileage: 2500
Primary Sled: 1979 yamaha 440 exciter
Where I sled: ontario
Posts: 62
Default

I HAD THAT CLICKING SOUND TOO MORE LIKE A RACHETTING?

ON MINE IT WAS 2 PROBLEMS THE LIMITER STRAP WAS OFF AND

THE TRACK WAS LOOSE , AFTER THE SKID REBUILD AND TIGHTENING THE TRACK UP

ITS GONE NOW

I CHECK THE DRIVE GEARS AND THE TEETH ON THE INSIDE OF THE TRACK WHILE

YOUR LOOKING AT IT TOO.
materman is offline   Reply With Quote
Old 02-07-2006, 05:24 PM   #4
sledman92
Senior Member
 
sledman92's Avatar
 
Join Date: Nov 2005
Location: Soo Ontario
Mileage: 820 kms
Primary Sled: 2007 Venture GT..1992 Phazer 2 st
Where I sled: Northern Ontario
Posts: 293
Default

Sounds like your track is loose...My Phazer ST wii do 90 mph ( spedo) I have a AAEN pipe on it.....A fresh belt helps out on performance......
Attached Images
File Type: jpg 1992_Phazer.jpg (83.4 KB, 109 views)
sledman92 is offline   Reply With Quote
Old 02-08-2006, 07:45 PM   #5
Yamahammer
Senior Member
 
Yamahammer's Avatar
 
Join Date: Aug 2004
Location: Espanola, Ontario, Canada
Mileage: 780kms
Primary Sled: 2000 Venture 500 XL
Where I sled: Espanola, Killarney, Sudbury
Posts: 568
Default

Mine has done 77mph on the GPS so far, and it read just over 130 on the speedo. Iv seen over 150 on the speedo so im just waiting to go check out another drag strip as the one made on my local lake got burried.

Hey Akrievins, sledman92 has got a pipe!!

Sledman92, can you tell us of what you had to do as for clutching and jetting after the pipe, PLEASE!, or any other mods.
__________________
http://i39.photobucket.com/albums/e1...d_editedCS.jpg
Tuning Forks Forever!

USI VX-301 skis
Studboy 9" Shaper Bars
136" Ripsaw Track
108 1.325" Woodys Stainless Steel Studs
Woodys Big Nuts
GYT-R hood Brackets
GYT-R Skidplate
NGK Iridium Sparkplugs
Amsoil Interceptor Oil
Fitch Fuel Catalysts
Shockpros Shock Covers
Powermadd 3" Riser Block
Powermadd Throttle Cable Extension
NTN blueseal Bearings
Medium Height Tint Windsheild
Custom Liscense Plate
Sportech Blue Lightsheild
Zenon Headlight Bulb
Yamahammer is offline   Reply With Quote
Old 02-08-2006, 09:11 PM   #6
CORY9
oldslowsledder
 
CORY9's Avatar
 
Join Date: Mar 2003
Location: Parry Sound,Ontario
Primary Sled: 2010 GSX, wife 08 Vector
Where I sled: North of Parry Sound
Posts: 6,491
Default

Track tension absolutely. Also have a look at the belt, and when were the clutches serviced last, perhaps you are not getting full shift-out.
__________________
2010 GSX
Wife 08 Vector
Son 2012 Nytro XTX
CORY9 is offline   Reply With Quote
Old 02-09-2006, 12:42 AM   #7
Yamaha-ha-ha
Senior Member
 
Join Date: Jan 2005
Primary Sled: 1991 Yamaha Phazer
Where I sled: Northern Wisconsin
Posts: 106
Default

I was thinking about a pipe for mine as well. I'd really like to hear what needed to be changed to keep things running right. Are you happy with the change in performance? How loud is it? Was it worth the money?
Yamaha-ha-ha is offline   Reply With Quote
Old 02-09-2006, 01:15 AM   #8
akrievins
Senior Member
 
akrievins's Avatar
 
Join Date: Feb 2005
Location: Mississauga, Ontario
Mileage: 75 kms
Primary Sled: 2003 Yamaha SXViper
Where I sled: Rosseau + Parry Sound, Ontario.
Posts: 586
Send a message via MSN to akrievins
Default

Quote:
I was thinking about a pipe for mine as well. I'd really like to hear what needed to be changed to keep things running right. Are you happy with the change in performance? How loud is it? Was it worth the money?
[/b]
Waiting to hear about this as well. I don't want to go overboard with mods, but a little more top end would be awesome. I don't see how I could sell this Phazer. It does everything I want it to.
__________________
When Hell freezes over... I'll snowmobile there too!
-----------------------------------------------------------------------
2003 Yamaha SX Viper. 700 Triple

http://i48.photobucket.com/albums/f2...gniturepic.jpg
akrievins is offline   Reply With Quote
Old 02-10-2006, 09:31 AM   #9
sledman92
Senior Member
 
sledman92's Avatar
 
Join Date: Nov 2005
Location: Soo Ontario
Mileage: 820 kms
Primary Sled: 2007 Venture GT..1992 Phazer 2 st
Where I sled: Northern Ontario
Posts: 293
Default

I had to jet it just a bit to ensure reliability..( I will check to see exactly what I am running it i now..I believe it's 140s BUT I am not sure I will find out). I have found that the pipe is louder but to too much, the performance is better ( mid,top end )..I just put the pipe on about a month a go (300kms) so far so good..My buddy helps me out with most of the work this summer I am custom making a cold air intake ( hard to find one) and reeds so I am sure i will have to re jet again with a new track it should be a great play sled..But I won't go any father then that I don't want to blow it...I know how you guys feel with the Phazer,( Venture) great sleds but you just want a little more power but don't want to ruin the fact that it is the most reliable sled on snow !!! As for clutching I am still playing with it, I don't have that worked out just yet!!!
sledman92 is offline   Reply With Quote
Old 04-05-2008, 09:42 PM   #10
piped 700xc
Junior Member
 
Join Date: Mar 2008
Primary Sled: 98 polaris 700xc/ 86 yamaha phazer
Where I sled: michigan
Posts: 18
Default

My 86 does about 90 according to the speedo on the lake I weigh about 140 though
piped 700xc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:21 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.