92 Indy 500 Sp Efi Bogs - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > POLARIS

Reply
 
Thread Tools
Old 02-05-2007, 07:43 PM   #1
Polaristaz
Junior Member
 
Join Date: Jan 2005
Mileage: 30
Primary Sled: 1989 Polaris Indy 500 Classic
Where I sled: Mohawk Valley
Posts: 6
Unhappy

Need some sane help. Bought a 92 Indy SP EFI last year and it ran great the end of the season. Ran stabilizer through before storing. Cleaned tank out and ran new gas / plugs (BR9ES) this year and she just bogs after about 5 minutes of idling or riding. Have to feather the heck out of it to keep running, then a good punch or kick and she'll take off for about 20 yards before bogging again.

Changed the fuel filter before the pump, checked the pump with direct power and it pumps steady. Both carbs move free (looked with air box off).

I can't think of anything else for the life of me.

My 89 Indy Classic, hell i've flipped that bad boy and other than a touchy clutch that doesn't like to idle has never given me this much trouble.
Polaristaz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-05-2007, 09:13 PM   #2
team wisz
Senior Member
 
team wisz's Avatar
 
Join Date: Jan 2007
Location: mitchell ontario
Mileage: 2800 miles
Primary Sled: 99 ski doo gts 800/99gts 700
Where I sled: mid western ontario
Posts: 252
Default

try running BR8ES plugs. my wifes sled is a 93 500 and we had br9es the dealer put in that did the service. i called another dealer and thats what he said to try.it worked great no problems since.but it ran the same as yours,might not be the problem but it is a cheap start.it worked for us very well. one more thing make sure new plugs are gapped properly. the dealer where i now buy my stuff does it for us. that sled has never run better.
__________________
let it snow let it blow i'm ready lets go
team wisz is offline   Reply With Quote
Old 02-05-2007, 10:39 PM   #3
Dave600
Senior Member
 
Dave600's Avatar
 
Join Date: Sep 2006
Location: Sudbury
Primary Sled: 2002 MXZ Renegade 800
Where I sled: Sudbury ON.
Posts: 593
Default

Quote:
try running BR8ES plugs. my wifes sled is a 93 500 and we had br9es the dealer put in that did the service. i called another dealer and thats what he said to try.it worked great no problems since.but it ran the same as yours,might not be the problem but it is a cheap start.it worked for us very well. one more thing make sure new plugs are gapped properly. the dealer where i now buy my stuff does it for us. that sled has never run better.[/b]

Cheap start until you melt a hole in your piston. If it ran well last year and nothing else changed except the summer storage, than chances are the problem is from sitting. If your jetted for the br9es and you throw a hotter plug in you will have a hot spot and it will melt, i have done it myself on my indy 500, the guy i bought it from had 8 in it and one cold cold night i melted it. It sounds to me like bad gas or plug. what do the plugs look like when you pull them out after it starts bogging?
__________________
Sleds

2002 MXZ Renegade 800
2002 MXZ 800
1996 Formula Z 583
1999 Formula DLX 380
1997 Grand Touring 500
1990 Indy 500 x 2
1987 Indy Sport
Dave600 is offline   Reply With Quote
Old 02-12-2007, 08:14 PM   #4
Polaristaz
Junior Member
 
Join Date: Jan 2005
Mileage: 30
Primary Sled: 1989 Polaris Indy 500 Classic
Where I sled: Mohawk Valley
Posts: 6
Unhappy

Plugs are a little dark / oily for my likes.

Not sure what's up now, I took it out for a ride sunday and feathering was able to keep it running when it tried to bog out. Sucks to stop and have to keep idle high, it's like driving with two feet.

I'm wondering if the TPS could be dying, but not sure how to diag it, any suggestions?
Polaristaz is offline   Reply With Quote
Old 02-12-2007, 08:39 PM   #5
Dave600
Senior Member
 
Dave600's Avatar
 
Join Date: Sep 2006
Location: Sudbury
Primary Sled: 2002 MXZ Renegade 800
Where I sled: Sudbury ON.
Posts: 593
Default

My suggestion would be to convert it to carbs, not sure how you feel about efi but once those old systems start to go downhill it might be worth your while to give up on it and just get a set of used indy 500 carbs.
__________________
Sleds

2002 MXZ Renegade 800
2002 MXZ 800
1996 Formula Z 583
1999 Formula DLX 380
1997 Grand Touring 500
1990 Indy 500 x 2
1987 Indy Sport
Dave600 is offline   Reply With Quote
Old 03-03-2007, 10:07 PM   #6
dwillowguy
Member
 
Join Date: Dec 2006
Location: Alberta
Mileage: 270 MILES
Primary Sled: 92 POLARIS 500 SKS EFI
Where I sled: ROCKIES
Posts: 40
Default

Had similar problem with mine....... ended up being PTO hole down to 50-60 lbs compression, rings were bad for sitting for 3 years not running.
dwillowguy is offline   Reply With Quote
Old 03-04-2007, 08:23 AM   #7
MP33
Junior Member
 
Join Date: Mar 2007
Location: Medford, Wi
Mileage: 200
Primary Sled: 96 Ultra 680 or 92 Indy 500
Where I sled: Wisconsin
Posts: 5
Default

Hello, Not trying to hyjack this post. But I to have the same sled with the same problem and would like to know what is all involved in switching a 92 Indy 500 EFI over to carbs? I have a pair of 38mm Indy 500 carbs. Is it just a matter of getting differant carb boots and bolting them on? How about the CDI? Is it controled through the computer? Sorry for so many questions but this may help others with the same problems....Thanks.....Mike
MP33 is offline   Reply With Quote
Old 03-04-2007, 12:53 PM   #8
dwillowguy
Member
 
Join Date: Dec 2006
Location: Alberta
Mileage: 270 MILES
Primary Sled: 92 POLARIS 500 SKS EFI
Where I sled: ROCKIES
Posts: 40
Default

No, not that simple, yes you will need new boot's as well as the airbox, Efi componets can all be removed...ie fuel pump,relays battery boc ..etc. Biggest problem will be in install the impulse line for the carb system.....where the crankcase sensor temp sensor is on the Efi, that hole is not drilled through into crankcase and has to be drilled out and then a 1/4 barb fitting screwed in so that it will operate the fuel pump. Problem is went you drill it out there will be some metal that will fall into crankcase. We presurized the crankcase with compressed air to about 4-5lbs pressure as we drilled it out.....theory being the pressure would blow out rather than falling into crankcase, we also greased the drill bit up really good as we drilled so fillings would stick to grease and was cleaned often.We finally flushed case with diesel fuel.

dwillowguy is offline   Reply With Quote
Old 03-04-2007, 04:58 PM   #9
MP33
Junior Member
 
Join Date: Mar 2007
Location: Medford, Wi
Mileage: 200
Primary Sled: 96 Ultra 680 or 92 Indy 500
Where I sled: Wisconsin
Posts: 5
Default

Thanks dwillowguy, I'll give it a try. How about the wiring harness? Will that work?



Quote:
No, not that simple, yes you will need new boot's as well as the airbox, Efi componets can all be removed...ie fuel pump,relays battery boc ..etc. Biggest problem will be in install the impulse line for the carb system.....where the crankcase sensor temp sensor is on the Efi, that hole is not drilled through into crankcase and has to be drilled out and then a 1/4 barb fitting screwed in so that it will operate the fuel pump. Problem is went you drill it out there will be some metal that will fall into crankcase. We presurized the crankcase with compressed air to about 4-5lbs pressure as we drilled it out.....theory being the pressure would blow out rather than falling into crankcase, we also greased the drill bit up really good as we drilled so fillings would stick to grease and was cleaned often.We finally flushed case with diesel fuel.[/b]
MP33 is offline   Reply With Quote
Old 03-04-2007, 06:33 PM   #10
dwillowguy
Member
 
Join Date: Dec 2006
Location: Alberta
Mileage: 270 MILES
Primary Sled: 92 POLARIS 500 SKS EFI
Where I sled: ROCKIES
Posts: 40
Default

As far as wiring harness went, I got one off e-bay for about 10 buck's, this way you don't have all those plugs going to no where.......look's neater.
dwillowguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:22 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.