1989 Safari 377 - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > SKI-DOO

Reply
 
Thread Tools
Old 12-20-2007, 06:04 PM   #1
osylazz
Junior Member
 
Join Date: Dec 2007
Primary Sled: safari 377
Posts: 2
Default

Greetings

The 1989 Safari 377 have a constant problem of fouling plug on #1 Cyl ( clutch side). Friend told me that it is probably the the crank seal causing this prob. I got the carb rebuild and rejetted etc. Runs smotther without cracking sound finally. The last issue is: spark plug. Wow, The fan side spark plug is a lovely brownish coulour as for the clutch side, black and cold. My solution while finding a solution is changing spark plug #1 to #2 cyl vice versa.
I tried running mix fuel ratio 60:1 no changes ( removed the oil jet pump and plugged both oild supply line).

Any suggestion from experience snowmobile maintainer. Perhaps a link on how to replaced crankshaft seal..etc.

Help will be greatly appreciated

Regards

Safari owner
osylazz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:55 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.