1996 Ski Doo Formula III question... - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > SKI-DOO

Reply
 
Thread Tools
Old 12-31-2008, 02:16 PM   #1
NDFormulaIII
Junior Member
 
NDFormulaIII's Avatar
 
Join Date: Dec 2008
Location: Minot AFB, ND
Primary Sled: 1996 SkiDoo Formula III
Where I sled: North Central ND
Posts: 3
Send a message via Yahoo to NDFormulaIII
Default 1996 Ski Doo Formula III question...

I am looking at buying a 1996 Formula III. I drove nearly 250 miles (round trip) today to ake a look and a test ride. I have owned the same sled before, however this one seemed to take a bit more for the clutch to engage. It has been a while but this one wasn't engaging until just until 6000rpm's. Is this correct? All together it seems to be a good deal, he is asking $1000, it does need a new seat and new handle bar covers as the plastic is missing. It still has a huge amount of power and speed. I am just concerned about the high RPM start, please help I am hoping to buy on Friday. Thanks.
NDFormulaIII is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-01-2009, 04:22 PM   #2
billww
Premium Member
 
billww's Avatar
 
Join Date: Feb 2007
Location: wisconsin Beaver dam
Mileage: 1500++
Primary Sled: 1998 Summit 670 600zl cat
Where I sled: WIS Beaver Dam Or a snow coverd lake
Posts: 1,394
Send a message via Yahoo to billww
Default

Thats sounds high my 670 hits at about 4800 , your could just need cleaning or a new belt how did it shift while you were riding?
__________________
670 SKIdoo

Last edited by billww; 01-01-2009 at 04:27 PM.
billww is offline   Reply With Quote
Old 01-01-2009, 09:08 PM   #3
NDFormulaIII
Junior Member
 
NDFormulaIII's Avatar
 
Join Date: Dec 2008
Location: Minot AFB, ND
Primary Sled: 1996 SkiDoo Formula III
Where I sled: North Central ND
Posts: 3
Send a message via Yahoo to NDFormulaIII
Default

It's a newer belt looking at it, it seems to be shifting okay, I endedup buying it today because I was able to pick it up for $500!! Did a little wheeling and dealing to get it that low. I took it out today to fuel it up and it seems to fluctuate while holding the throttle steady. I was running in deep powder most the time but it still seemed to have problems holding a steady RPM. I am hoping maybe a tune-up and some new clutch springs will help, any ideas?

Last edited by NDFormulaIII; 01-02-2009 at 02:27 PM.
NDFormulaIII is offline   Reply With Quote
Old 01-05-2009, 03:42 PM   #4
J-Bone
Junior Member
 
Join Date: Mar 2008
Location: Kingston
Mileage: 1300
Primary Sled: 1998 formula deluxe 583
Where I sled: North of Seven
Posts: 28
Default

sometimes when guys are selling sleds they will put a new looking belt on but might be from another sled. this being said does the belt come to a rest at the top of the secondary?
flush with the top ? if not it could be the wrong belt and this would explain the high rev take-off's, new clutch springs are a great idea and make sure you give it a good cleaning too.....Happy trails
J-Bone is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:43 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.