Sled-bed Trailers - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING SECTION > GENERAL SNOWMOBILING

Reply
 
Thread Tools
Old 11-17-2002, 11:34 AM   #1
mxzdude
Member
 
Join Date: Oct 2002
Location: Up-state NY
Where I sled: Tug Hill,NY St Zenon, Canada
Posts: 75
Default

I was looking at purchasing a Sledbed 10' trailer with a sled dock enclosure. This is my first time with either poduct. Do the wiring harnesses hold up? Comments on either please?
mxzdude is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-17-2002, 06:57 PM   #2
mark1965
Junior Member
 
Join Date: Nov 2002
Where I sled: Michigan
Posts: 3
Default

Buddy bought a sled bed drive on/drive off 2 years ago with a Bearcat cover. The trailer is good. Pretty well made. He has had a few minor problems. A trim piece ripped off by a cardide runner. The trim wasn't installed well enough. One of his lights keeps shorting out and they can't seem to solve the problem. And the lockes that came woth the cap frooze up and actually broke in his hand on one trip.

I bought a Floe 10' tilt about the same time. I love it. It awesome. I did have to replace the harness this year. One of the posts corroded and broke off.
mark1965 is offline   Reply With Quote
Old 11-17-2002, 07:05 PM   #3
Bartman
Senior Member
 
Join Date: Mar 2001
Location: Maine
Posts: 373
Default

I have a Sled Bed I bought new in 2000, no problems with the wiring, but the aluminum welds on the under side of the frame work started to crack after a year, out of warrantee of course, I have e-mailed the company and have had no response from them so my next trailer will be something other than a Sled bed, oh ya I noticed the dealer that I bought it from doesn't carry them anymore either.
__________________
2004 Ski-Doo Renegade 600HO

1999 Formula III 700 (SOLD), I'll miss her it was a great sled

2002 GMC Sierra 1500 ext. cab 4x4
Bartman is offline   Reply With Quote
Old 11-17-2002, 07:54 PM   #4
mxz7
Senior Member
 
mxz7's Avatar
 
Join Date: Dec 2001
Location: Pete @ Watertown,WI
Primary Sled: 05 MXZX 600 SDI ~Black~
Where I sled: Wisconsin and da U.P.
Posts: 3,522
Send a message via MSN to mxz7
Default

A friend had one. Welds cracked,same old same old.

He bought a Triton,best in the biz.
__________________
Snowtrails TV
mxz7 is offline   Reply With Quote
Old 11-18-2002, 01:05 AM   #5
99SRX700
Senior Member
 
Join Date: Jan 2002
Posts: 259
Default

I met a guy at work a while back who was telling me how the tongue on his floe snapped. Apparently this is more common with aluminum trailers than most of us think, at least thats what the people who fixed it for him said. IMO I would go with a brand that is known for its quality and a wishbone tongue is a must. I have heard a lot about the welds cracking on the sled beds also. I would go with a Triton, I am sure there are others who build good trailers but you can't go wrong with Triton.
99SRX700 is offline   Reply With Quote
Old 11-18-2002, 07:21 AM   #6
PAZR700
Member
 
PAZR700's Avatar
 
Join Date: Oct 2002
Location: North East Pennsylvania
Posts: 85
Default

I bought a used Flow 2 years ago. Had to fight with kights everytime I went anyplace last year. Spent $90 in lights and wiring and completely rewired and lighted the whole thing. Looked like most of the problem was with the lights and not the harness. While I was at it inspected everything real good. Ended up replacing hub bearings, but who knows how many miles are on it The trailer is a 94 but as good as new now. There were NO problems with any of the welds
__________________
00 ZR 700 (black) Mine
01 ZR 500 (Green) Wifes
98 Blazer
01 Suzuki Quadmaster 500 (mine)
98 Suzuki Quadrunner 250 (wife/kids)
PAZR700 is offline   Reply With Quote
Old 11-18-2002, 08:19 AM   #7
mxzdude
Member
 
Join Date: Oct 2002
Location: Up-state NY
Where I sled: Tug Hill,NY St Zenon, Canada
Posts: 75
Default

Thanks guys. I think I'll look for a Triton even though it's a little more.
mxzdude is offline   Reply With Quote
Old 11-18-2002, 10:03 AM   #8
SNO N YET
Senior Member
 
SNO N YET's Avatar
 
Join Date: Oct 2002
Location: Jackson, WI
Mileage: WAITING
Primary Sled: 99 ZR 600 EFI
Where I sled: WI & the U.P.
Posts: 479
Send a message via ICQ to SNO N YET
Default

GO TRITION!

They are built in my backyard!

TRITON TRAILERS
SNO N YET is offline   Reply With Quote
Old 11-18-2002, 11:50 AM   #9
Mikadoo
Senior Member
 
Mikadoo's Avatar
 
Join Date: Nov 2001
Location: S-E Lower, Michigan  
Mileage: 1115 miles
Primary Sled: The old purple pile
Where I sled: Frederic to Lake Gogebic & everywhere in between
Posts: 2,422
Send a message via Yahoo to Mikadoo
Default

This same thread came up last year. That's when I discovered the 2 main frame rail were broke in two where the axle mounts [sled bed drive-on drive- off]. The company was willing to send 2 new rails but only the same, too short, thin hunk of junk that was already there!
I went to the iron works place picked up 2- 2x4x1/4x10' aluminum tube and fixed it right myself! Several on here had the same problem, stay away from Sled Bed !!!
__________________
Your wannabe information center----may I help you?

2000 Flll 800
SC3 x 136 with a 1.5 track.
MXZ racing shocks up front with precision skis.
Clutched & geared by Joey.
And now RER, ya baby!
Mikadoo is offline   Reply With Quote
Old 11-18-2002, 12:10 PM   #10
jdsmi
Senior Member
 
jdsmi's Avatar
 
Join Date: Aug 2001
Location: EastCentral MN * * * (just N of TwinCities)
Where I sled: East Central Minnesota - I want to go back to the UP though
Posts: 757
Default

Has anyone experienced the frame breakage problems on other than the 10' Sled Beds? I have a '00 12' and the main beams look alot heavier than the 10' beams.

As far as the welds go, that's a little un-nerving and will have to watch closely. They look OK now.
jdsmi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:38 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.