1980 Citation Snowmobile 377 - One clynder No Spark - Snowmobile World : Your #1 Snowmobile Forum
http://www.snowmobileworld.com/forums
» Sponsors
Go Back   Snowmobile World : Your #1 Snowmobile Forum > SNOWMOBILING EXTRAS! > VINTAGE SLEDS

Reply
 
Thread Tools
Old 12-17-2010, 12:34 PM   #1
planethax
Junior Member
 
Join Date: Dec 2010
Posts: 2
Default 1980 Citation Snowmobile 377 - One clynder No Spark

1980 Citation Snowmobile 377 - One clynder No Spark

Found this add and wondering what could be the issue.
Read points were problematic but would that effect only 1 cylinder?

Wondering if this would be a good sled to get for my son.
(guy looking for $500)

Quote:
Originally Posted by FoundAd

Im selling my 1980 Citation sled. Was running perfectly fine until one cylinder lost spark, and wasnt running fine. This is my first sled. I just bought it less than a week ago, and I dont want to spend the time to fix whatever the problem may be. I am not mechanically inclined, its probably just faulty wires. Something as simple as that i was told. This is a perfect sled for someone who has the know how. Its in exceptional shape, No rot whatsoever. Belly pans are in great shape. The hood is like new, the seat has no rips. I even have the ownership and sticker aswell. As I had just recently registered it. There is tons of compression, 110 psi. its getting spark, carb had been rebuilt, racing clutch, 2 new coils.. Like I said it must be something minor. I have no time.
planethax is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-18-2010, 09:49 AM   #2
mmgg
Senior Member
 
Join Date: Feb 2010
Location: thunder bay ontario
Mileage: 850miles in 10/11
Primary Sled: 600 polaris
Where I sled: 300 miles around thunder bay
Posts: 537
Default

I don't know if a 1980's sled would have points.
mmgg is offline   Reply With Quote
Old 12-23-2010, 08:41 PM   #3
comeonsnow
Junior Member
 
Join Date: Sep 2010
Location: Kokomo, IN
Primary Sled: 1979 Yamaha Enticer 300
Where I sled: Indiana Trails and fields
Posts: 18
Default

Actually yes, this sled has points. The 377 is a Citation 4500 with a 377 engine. It has a magneto that has a generator coil, two condensers and two sets of points. Each set of points feeds an external ignintion coil that is mounted to the side of the engine. The spark plug wires go from the external coils to the plugs (obviously ).

So if you only have spark on one cylinder, I would bet that the external ignition coil for that cylinder is bad. ( I just replaced both of them on my 1980 Ski-Doo Everest) Could be the Plug wire or spark plug boot, but I doubt it. You can get a new coil for about $20.

Good Luck.
comeonsnow is offline   Reply With Quote
Old 12-31-2010, 12:32 AM   #4
slugger
Junior Member
 
Join Date: Dec 2010
Posts: 5
Default

Im working on the same sled now i just put new points in and put new coils on and i still can only get spark in one cylender
slugger is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:04 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.