Polaris IQ 750 turbo check engine - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 12-24-2017, 03:52 PM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 2
Polaris IQ 750 turbo check engine

We just got our 2-up this year and have rode it one time and the check engine light came on after about an hour. It only came on (didnít flash any codes or enter into limp mode). We put it on the trailer just to be safe. Took it back to our local dealer to have them run diagnostics on it and the code was like throttle pressure sensor (thinks that the turbo is over-boosting...even during idle). Took it down to the sensor, which involved taking off the gas tank and replaced the sensor...nope. They are in the process of looking thru the wiring harness for shorts, frayed wires etc. said the engine is great. The turbo is great but they arenít able to find out why it keeps throwing the code. Anyone had this issue? Will it hurt to drive with this code (check engine light). Thanks anyone
Dannymarkley is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-25-2017, 09:43 AM
Senior Member
 
SnoKing's Avatar
 
Join Date: Mar 2002
Location: Pence WI
Posts: 575
Send a message via Yahoo to SnoKing
You didn't mention what year the sled is. 06 was first year that had a lot of problems and recalls. Mine was and 08 and they had a lot of those where the wiring was pinched under the engine.

As a warning , check the smell of your oil. If you smell gas in the oil change the oil when you do.

Can't help you with your specific problem but below is the best website for info on those sleds

Polaris Files (Powered by Invision Power Board)

Merry Christmas

It's cheaper to replace the decals, then build up a little sled. The first time I drove a snowmobile was 7/4/72. It was a 71 488 Polaris Charger.
Previously owned sleds:
1970 433 Polaris.Mstng, 2013 MXZ 600 ACE
1974 530 Cust II, 2012 MXZ XR 1200
1975 SS250, 2014 900 A RENE ADREN
1976 TX 440
1978 TXL 340
1979 TXL 340
1979 Cent 500
1980 TXL Indy
1981 Indy 500
1984 600 LE
1986 Trail Indy SP
1986 600 SE
1988 400 SKS
1989 Indy 650 ( 3)
1990 Original RXL
1992 500 EFI SKS
1993 RXL SKS
1995 RXL
1997 Ultra Touring
1998 Indy 500
1998 500 Classic touring
2001 800 XC/SP (2 )
2002 550 Classic
2002 800 XC/SP
2002 800 Vertical Edge
2005 900 Fusion
2006 600 H.O Fusion
2006 900 Fusion
1974 440 Electra
2008 600 CFI LX
2008 FST LX
2008 D700 RMK 163
09 D600 Swbk
11 Pro R 600
SnoKing is offline  
post #3 of 6 (permalink) Old 12-25-2017, 10:06 AM Thread Starter
Junior Member
 
Join Date: Dec 2017
Posts: 2
Quote:
Originally Posted by SnoKing View Post
You didn't mention what year the sled is. 06 was first year that had a lot of problems and recalls. Mine was and 08 and they had a lot of those where the wiring was pinched under the engine.

As a warning , check the smell of your oil. If you smell gas in the oil change the oil when you do.

Can't help you with your specific problem but below is the best website for info on those sleds

Polaris Files (Powered by Invision Power Board)

Merry Christmas
Itís a 2013 with 900 miles. Thanks for your help. Merry Christmas to you as well
Dannymarkley is offline  
post #4 of 6 (permalink) Old 12-26-2017, 09:06 AM
Senior Member
 
SnoKing's Avatar
 
Join Date: Mar 2002
Location: Pence WI
Posts: 575
Send a message via Yahoo to SnoKing
You're welcome.

I believe 2013 was the last year Polaris built those snowmobiles

It's cheaper to replace the decals, then build up a little sled. The first time I drove a snowmobile was 7/4/72. It was a 71 488 Polaris Charger.
Previously owned sleds:
1970 433 Polaris.Mstng, 2013 MXZ 600 ACE
1974 530 Cust II, 2012 MXZ XR 1200
1975 SS250, 2014 900 A RENE ADREN
1976 TX 440
1978 TXL 340
1979 TXL 340
1979 Cent 500
1980 TXL Indy
1981 Indy 500
1984 600 LE
1986 Trail Indy SP
1986 600 SE
1988 400 SKS
1989 Indy 650 ( 3)
1990 Original RXL
1992 500 EFI SKS
1993 RXL SKS
1995 RXL
1997 Ultra Touring
1998 Indy 500
1998 500 Classic touring
2001 800 XC/SP (2 )
2002 550 Classic
2002 800 XC/SP
2002 800 Vertical Edge
2005 900 Fusion
2006 600 H.O Fusion
2006 900 Fusion
1974 440 Electra
2008 600 CFI LX
2008 FST LX
2008 D700 RMK 163
09 D600 Swbk
11 Pro R 600
SnoKing is offline  
post #5 of 6 (permalink) Old 12-27-2017, 09:30 AM
Junior Member
 
Join Date: Dec 2017
Posts: 20
Good info here!
JedFalls is offline  
post #6 of 6 (permalink) Old 11-10-2019, 09:08 AM
Junior Member
 
Join Date: Nov 2019
Posts: 2
Have a Polaris FST IQ Turbo, 2010 sled. Just installed a new ignition switch and now the Check Engine Light is on.
GeorgeElder is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome