Brake Problems with Snowmobile. - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-03-2019, 08:25 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 1
Brake Problems with Snowmobile.

I have a 2003 Yamaha mountain max 700 triple. The brakes do not work at all when you squeeze the brake lever. Also when you are driving it the brakes make a squealing noise but if you put just a little pressure on the brake lever the noise quits but still no brakes at all. What could be the problem? Thanks
John Malli is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome