Hello! and Help. - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-06-2019, 07:58 AM Thread Starter
Junior Member
 
Join Date: Feb 2019
Location: Finland
Posts: 1
Hello! and Help.

Well i just joined, i've got some problems with my 2008 Polaris IQ 600 Shift. I have spark on both cylinders and both cylinders get fuel but it still runs on only one cylinder, it starts within the first 5 pulls. Its only got 1600 miles on it. When i've ridden for a while it usually starts running on both again.
nico2468 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome