2008 crossfire 5 flooding out - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-07-2010, 05:39 PM Thread Starter
Junior Member
 
Join Date: Apr 2010
Posts: 4
2008 crossfire 5 flooding out

good day guys I have crossfire 5 thats flooding out after I hit 5200 rpm on the trail but it runs good on an ice road,, I did a test on the voltage regulator & it reads 14.46 volts don't now what to do. Any help is greatly appreciated
stanoot is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-14-2010, 01:08 PM
Member
 
Hypnotoad's Avatar
 
Join Date: Oct 2010
Location: www.backcountryrebels.com
Posts: 71
clean you powervalves, the sled is also EFI so it's kinda hard to flood
Hypnotoad is offline  
post #3 of 4 (permalink) Old 12-19-2010, 12:24 AM
Junior Member
 
knoppers's Avatar
 
Join Date: Dec 2008
Location: palisade, mn
Posts: 18
its EFI, its not flooding out. something else is wrong.
knoppers is offline  
 
post #4 of 4 (permalink) Old 07-19-2012, 12:36 AM
Junior Member
 
Icyskis's Avatar
 
Join Date: Jul 2012
Location: minnesota
Posts: 26
My uncles sled does the same thing he dumped lots of money into it and brought it in tons of times and it still does the same thing
Icyskis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome