Safari - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-07-2016, 10:03 PM Thread Starter
Junior Member
 
Join Date: Jan 2016
Location: Wawa, ON
Posts: 2
Safari

so i had the same issue before the 503 swap anyways but thought you should know about the swap, so my tail light is bipolar lol it likes to work whenever it wants to work, sometimes it only turns on when i press the break, sometimes its on normally, sometimes it dosent even work, and the headlight, well the headlight is the same except it will dim low turn of for a second when i stop the machine start back up and go for awhile on a smooth trail works fine, once i hit the roads and start hitting bumps going quite fast, the light will flicker sometimes, it will go really bright, then it will just blow up, switch it to high beam same thing happens, could anyone help me on this problem, as i said before it was the same problem before i did the engine swap its as if theres a loose ground or something somewhere, is there some sort of voltage regulator i should be aware of??
devonparisee is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome