Need Help - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-18-2020, 11:44 PM Thread Starter
Junior Member
 
Join Date: Jan 2020
Location: Minocqua, WI
Posts: 2
Send a message via MSN to Tom Mix Send a message via Yahoo to Tom Mix
Need Help

I have a 1999 Arctic Cat Triple Touring. Just had it in the shop and had the carbs cleaned and a new fuel filter installed. Problem is that after around 5 miles, I lose power. Sled will still idle, but when giving gas, the engine bogs. Engine will still start when doing the bogging mode. If I let it sit for a half hour, the sled runs like a top for a while and then repeats the bogging. Checked plugs and they look to be OK, no crap on them. Also when in bogging mode, if you give it gas long enough, the engine backfires. Could it be the brain box, the coils or something else? It is a water cooled engine, but I don't think that its over heating. If it was over heating, you would have a difficult time starting it and keep it running. Like I said, it idles good. PLEASE HELP!!!!!!
Tom Mix is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome