1997 Polaris Trail - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-26-2018, 11:57 AM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 2
1997 Polaris Trail

Alright so 3 years ago i was riding my dads 1997 polaris trail to school when it suddenly started to bog, i thought i saw something come off the sled but could not find anything. The Sled would not move under its own power and would not idle right. Got it home and took the carbs apart cleaned them and put them together, still did the same thing, if the air box is off it will idle but still not move under its own power. Lifting it solves the moving problem the track will spin easy. it has good compression it was one of the first things we checked. we swapped carbs and that did not work. we have checked to see if anything is preventing it to move when on the ground but nothing. this problem has had me, my dad, and my friends quite stumped. any help would be awesome.
Madshifter is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome