1995 Polaris Indy 500EFI bogging down after warmup - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 02-15-2020, 02:29 PM Thread Starter
Junior Member
 
Join Date: Jan 2020
Posts: 3
1995 Polaris Indy 500EFI bogging down after warmup

95 polaris 500 efi - bogs down after warm up. I see others with similar problem. Machine runs fine for 20 min. Then it begins to bog down. Shut it off for 10 sec, something in ECU resets and it runs fine for 10 min, then begins bogging down again. Shut it off for 10 sec, runs fine for 10 min ... and so on. I see threads where others discuss similar problem but don't see a resolution. Any help?
If I need to replace chip, sensor, or ECU, any links to in-stock supplies?
TIA
James N. Graham is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-24-2020, 04:50 PM Thread Starter
Junior Member
 
Join Date: Jan 2020
Posts: 3
Fixed

SOLUTION- sprayed contact/electronics cleaner into each of the plugs for the EFI sensors and problem solved!?! (I already had changed the battery and the fuel filter). I tried unplugging the EFI sensors one by one to see if I could identify the faulty sensor. I knew it had to be an EFI issue because of the way the problem would vanish for 10 min if I shut it off. Something was resetting.
When I unplugged the sensor that runs to the bottom of the engine, the plug had both corrosion and ice crystals/water in it. I sprayed it out with cleaner and plugged it back in. For good measure, I cleaned out the other plugs as well, but I think that one was the problem. Now it runs great! I hope this helps someone else.
James N. Graham is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome