Exciter sx bogging/white smoke - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-31-2018, 07:07 AM Thread Starter
Junior Member
 
Join Date: Jan 2018
Posts: 3
Exciter sx bogging/white smoke

I have an exciter sx that ran great last year. Stored it, fogged the engine and it started up and ran fine late fall. Finally got some snow, went to take it for a ride seemed boggy even lifted on its stand. Figured it just needed to get the fogging out of it. But it got worse the longer it ran. Would not idle and white smoke hanging in the air.
Spark on both sides plugs looked ok(changed them anyway). Pulled the carbs had a sled head friend clean them properly. Put them back in a few pulls and a quick adjust on the idle and it was running perfect. Took it for a little rip, lots of power ran like new. Parked it, 2days later (last night) started it up idled fine, let it warm up, gave it a little throttle, not as responsive as normal. Idle some more try the throttle again even worse bog, then white smoke from the exhaust. Bogging even worse now and wont idle unless you hold on the gas a little. Just seems like there is no power ( like running on one cylinder).
leaking head gasket?
oil pump/ mixture?
like i said carbs were just cleaned and set up.
stevesx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome