Need Help With Tuning My Mod Sled - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-11-2002, 09:06 PM Thread Starter
 
Join Date: Nov 2002
Posts: 6
i bought a union bay 1000 motor it runs at 8900 260 h.p im lost with the tuning on this the sled is all lightened up i want to use it for 1000 ft speed runs and then summer asphalt please help if you can thanks the motor is in a 97 mach chassis skidoo
bigsled2000 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-12-2002, 10:19 PM Thread Starter
 
Join Date: Nov 2002
Posts: 6
HELP I REALLY NEED SOME IDEAS
bigsled2000 is offline  
post #3 of 3 (permalink) Old 11-14-2002, 09:36 PM
Senior Member
 
Alien's Avatar
 
Join Date: Nov 2002
Location: Stanchfield, MN
Posts: 158
Before you even start tuning I would think about the chassis first. If the engine has 260 hp, the stock motor mounts and mounting are not going to be enough. I would call Union and get a general jetting and clutching suggestion from them to start. I would always jet real rich till you can get a base line.
Alien is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome