voltage regulators - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 02-11-2015, 08:01 PM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 24
voltage regulators

Anyone have bad days because of voltage regulators... My 2008 Polaris IQ 800. Just toasted the ECU. Computer cause the regulator failed... Is this common or a freak
trailtramp is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-12-2015, 12:05 PM
Senior Member
 
retiredpop's Avatar
 
Join Date: May 2001
Location: Calgary,Alberta
Posts: 686
Sadly it is quite common. Polaris updated the regulator but did not issue a recall to owners. They replaced the early failures on a "goodwill" basis but of course that is no longer in effect. Engineering problem as far as I'm concerned in that they should have had a fail safe built in so if regulator packs it in the sled won't run. Regulator is expensive enough and ECU is even more so.

The older I get the better I was; In fact now that I think about it I am a legend.
retiredpop is offline  
post #3 of 9 (permalink) Old 02-13-2015, 08:12 AM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 24
So after I spend a grand.....there's no way of telling that it won't happen again... Not a great chance of staying with Polaris if this is the case
trailtramp is offline  
 
post #4 of 9 (permalink) Old 02-13-2015, 11:57 AM
Senior Member
 
BCDan's Avatar
 
Join Date: Nov 2002
Location: Oregon
Posts: 1,352
Pop, was the part number on the new regulator the same as the old? I've not had any issues with my 08, but would rather get ahead of that if possible...

2007 RMK 700, 2008 RMK 600, 1995 AC Prowler 2-up, 1980? AC Cheetah
BCDan is offline  
post #5 of 9 (permalink) Old 02-14-2015, 02:10 AM
Senior Member
 
retiredpop's Avatar
 
Join Date: May 2001
Location: Calgary,Alberta
Posts: 686
From what I have been able to track down the original VR was 4011731 in 2007/2008. Then changed to 4012476 in 2009/2010 which had some bad ones but not all were bad. They updated to 4012930 and the latest is 4013587. If you order a new one from the dealer you will get the 4013587 as the parts fiche at my dealer shows everything from 2007 and up is superseded by that one. I have a 4012476 in my 2010 and it has been good for 3500 miles so I guess I got a good one. I'm still deciding if I should get a spare or not.

The older I get the better I was; In fact now that I think about it I am a legend.
retiredpop is offline  
post #6 of 9 (permalink) Old 02-14-2015, 09:29 AM
Senior Member
 
BCDan's Avatar
 
Join Date: Nov 2002
Location: Oregon
Posts: 1,352
Thanks! I will get one of the new ones coming, I haven't been able to ride enough to break anything this year because of lack of snow, so I don't want the parts guys to forget what I look like

2007 RMK 700, 2008 RMK 600, 1995 AC Prowler 2-up, 1980? AC Cheetah
BCDan is offline  
post #7 of 9 (permalink) Old 02-14-2015, 10:52 AM
Senior Member
 
retiredpop's Avatar
 
Join Date: May 2001
Location: Calgary,Alberta
Posts: 686
Quote:
Originally Posted by BCDan View Post
Thanks! I will get one of the new ones coming, I haven't been able to ride enough to break anything this year because of lack of snow, so I don't want the parts guys to forget what I look like
LOL. I hear you, we're in the same situation around here as well.

The older I get the better I was; In fact now that I think about it I am a legend.
retiredpop is offline  
post #8 of 9 (permalink) Old 02-15-2015, 08:19 PM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 24
Well.. Pop. Good Info, thanks. Got my sled at the shop waiting for install of a new ECU and regulator... She tells me it's a different part number, I hope that the numbers match to something that will not fail again. I'll be chkin closely with that info you gave.We've got a load of snow now.. Hopefully I get back on the trail this week..Thankx again
trailtramp is offline  
post #9 of 9 (permalink) Old 02-15-2015, 11:49 PM
Senior Member
 
retiredpop's Avatar
 
Join Date: May 2001
Location: Calgary,Alberta
Posts: 686
Quote:
Originally Posted by trailtramp View Post
Well.. Pop. Good Info, thanks. Got my sled at the shop waiting for install of a new ECU and regulator... She tells me it's a different part number, I hope that the numbers match to something that will not fail again. I'll be chkin closely with that info you gave.We've got a load of snow now.. Hopefully I get back on the trail this week..Thankx again
You're welcome and I hope it all works out okay for you. Send some snow out our way!

The older I get the better I was; In fact now that I think about it I am a legend.
retiredpop is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome