Kawi intriguer 440 electrical problem - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-16-2012, 03:19 PM Thread Starter
Junior Member
 
Deere_Ridere19's Avatar
 
Join Date: Oct 2011
Location: Chatham On
Posts: 9
Kawi intriguer 440 electrical problem

I was wondering what my problem is. I seem to blow both light bulbs when i rev it up. Could it possibly be my coil, points or regulator?

1993 Skidoo Formula Plus X 583, 1979 Kawasaki Intriguer 440
Deere_Ridere19 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-20-2012, 06:56 PM
Junior Member
 
Join Date: Jan 2007
Posts: 20
Regulator most likely.
sledhead800 is offline  
post #3 of 3 (permalink) Old 11-05-2012, 06:37 AM Thread Starter
Junior Member
 
Deere_Ridere19's Avatar
 
Join Date: Oct 2011
Location: Chatham On
Posts: 9
Quote:
Originally Posted by sledhead800 View Post
Regulator most likely.
Im buying a new circuit board and regulator next weekend. Hopefully the problem is fixed!

1993 Skidoo Formula Plus X 583, 1979 Kawasaki Intriguer 440
Deere_Ridere19 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome