77 everest 340 e - Snowmobile World : Your #1 Snowmobile Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-17-2013, 08:09 PM Thread Starter
Junior Member
 
Join Date: Jan 2013
Posts: 29
77 everest 340 e

Hey guys, back again this year still trying to get my 77skidoo. everest 340 going. I cant get it running at all. Tons of spark, freshly cleaned carb new plugs. Pull and pull get nothing but wet plugs and fuel coming out the exhaust. Where do i start? Replaced points last year and got it going then it just kept flooding out. Thanks for any help
Raggsdale is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-18-2013, 07:54 AM
Senior Member
 
dlaine's Avatar
 
Join Date: Apr 2007
Location: Twin Cities MN
Posts: 536
Spark, fuel and compression and it will run.

Spark present and fuel running out of the exhaust would make me start with the carbs.

We had 69-73 ski-doo's growing up - not as familiar with the 77. Is it still using the Tillitson carbs the like the older ones? We would have to completely rebuild them EVERY fall - new gaskets, diaphragm and needle valves. If the rubber tip of the needle has even the slightest indentation left on it when you pull it out replace it.

Good Luck!
dave

Waiting for snow again...
dlaine is offline  
post #3 of 5 (permalink) Old 12-18-2013, 08:26 AM Thread Starter
Junior Member
 
Join Date: Jan 2013
Posts: 29
Yeah it runs a tillitson 148b. I rebuilt it last year and had it running one time, shut it down and wasnt able to start it again. Cleaned it the other day, everything still like new. Just doesnt want to start.
Raggsdale is offline  
 
post #4 of 5 (permalink) Old 12-20-2013, 08:06 AM
Senior Member
 
dlaine's Avatar
 
Join Date: Apr 2007
Location: Twin Cities MN
Posts: 536
Yeah - with ours it didn't matter how well we cleaned them. Every fall they needed a new rebuild kit. We would clean and clean and clean and spend hours trying to get it to start - wouldn't start. New rebuild kit in the carbs and they would start right up. I don't know what it was about those carbs - I was glad to see the last of them!!!

Also check the compression...

dave

Waiting for snow again...
dlaine is offline  
post #5 of 5 (permalink) Old 12-20-2013, 02:12 PM Thread Starter
Junior Member
 
Join Date: Jan 2013
Posts: 29
Im just gonna re seal the whole motor and see what happens
Raggsdale is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome