Snowmobile World : Your #1 Snowmobile Forum - Reply to Topic
Thread: Hi all! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Snowmobile World : Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-26-2019 02:31 AM
Rayver68 Welcome from another new member. You may want to post on the tech section for better exposure of your question.
07-18-2019 08:30 AM
thomaspanton Congrats on your new Arctic and nice looking too.
02-22-2019 11:38 AM
RobertJZ Okay, the picture did not go through, so I set it up as an avatar haha
I wanted to pst up my question in the Arctic Cat section but seems like I am not allowed to do so due to some reason.
So I will ask here, and hope forum moderators will move the post exactly where it belongs.

So, here is the problem. As I said before, I've got a 2011 Cat and there are certain things that need to be fixed.
I managed to revive all the electricity, though 1 problem couldn't be fixed. The speedometer is totally dead, along with the screens on the dash. I checked everything I could, with zero luck.
Now I thought of getting a new unit, maybe an aftermarket one.
Ones by Koso look reliable to me, et I will see what people say about them
https://www.powersportsid.com/koso/x...-bb026001.html
But before I start those experiments can you folks tell me what you think of this? Any recommendations?
Thanks.
02-22-2019 11:30 AM
RobertJZ A quick pic of my Cat
02-22-2019 11:29 AM
RobertJZ
Hi all!

Hi everyone,
I am a new owner of the Arctic Cat F8 SNO PRO LTD (2011). I picked it up last month, and at the moment I am working to get certain things fixed, so I joined your folks forum hoping you will help me with this project
Cheers!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome