Snowmobile World : Your #1 Snowmobile Forum

Snowmobile World : Your #1 Snowmobile Forum (https://www.snowmobileworld.com/forums/)
-   POLARIS (https://www.snowmobileworld.com/forums/134-polaris/)
-   -   plug fouling at low speed, 2006,900 switchback (https://www.snowmobileworld.com/forums/134-polaris/74128-plug-fouling-low-speed-2006-900-switchback.html)

sdenick 03-14-2009 03:15 PM

plug fouling at low speed, 2006,900 switchback
 
My '06, 900 Switchback seems to be running way too rich under 5600RPM. It actually loads up to the point of fouling plugs on a tight windy trail. Top end runs perfect. Is it possible to lean out the bottom end on these fuel injected engines? If so, how is it done? I assume it's done by programming? Any input appreciated.

Sled Dogg 03-22-2012 12:24 PM

You've got an issue. These EFI motors are smooth stock. Run the Polaris fuel injection cleaner through it first. Check that huge air box for obstructions, all the way to the reed cage. Found a VES GOLD Cap in my friends reed cage.

Sent from my MB855 using Snowmobile.com App

Sled Dogg 03-22-2012 12:28 PM

Also, CLEAN YOUR POWER VALVES!!!! I'LL bet that they are horrible. Bought a 600 XC SP Anniversary Edt from a friend. 2000 miles and he had never cleaned the valves. They were stuck!!! RIPPED down low after I cleaned them.

Sent from my MB855 using Snowmobile.com App


All times are GMT -5. The time now is 01:55 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome