Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,674 Posts
Discussion Starter #1
Just curious if anyone else has had there 800 twin overheat.i had recall done in the fall.It overheats after about 20min of operating(idiot light on).System hasn't been opened since recall but i bled it anyway just to ensure no air pockets but it still ran hot.This was in -6 degree weather as well,with lots of snow getting on heat exchanger.I checked ronnies parts page and it doesn't show a thermostat listed so that rules that out.
Any help or suggestions would be graetly appreciated.
 

·
Registered
Joined
·
93 Posts
There is a stat in the sled. My dealer told me that some of the stats in the 800 twins were falling apart for some reason.
When the dealers did the updates to the motor they were supposed to check the stat also to see if it was broke and if it was they were supposed to change that also.
Thats what my dealer told me.
I also have the '01 800 twin with the updates done but my stat was ok when they updated it, but I think this past weekend it might have broke.
josh
 

·
Registered
Joined
·
1,674 Posts
Discussion Starter #3
Thanks midmich800.I pulled the exhaust pipe and manifold off and luckily there is no visible damage to the pistons.I'm gonna call the dealer tomorrow(i need another recoil again
anyways)
 

·
Registered
Joined
·
1,674 Posts
Discussion Starter #4
I pulled her apart today and found that the thermostat was in several pieces.Figured i'de check the reeds as well while i had the tool box open and sure enough they were coming apart as well.Called my dealer first and it sounds like they will warranty it all.The dealer has actually been very good with me on all levels of service so my hat off to them.I just want parts only as i enjoy tinkering anyways(hiding in garage from wife).I just hope i can run it before all the snow melts to make sure all is ok.
 
1 - 4 of 4 Posts
Top