Snowmobile World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Does anyone else have the problem with it surging at 50-60mph when you hold it at a contast speed ?? If you give it a little more it goes away or let off it will also go away.
 

·
Registered
Joined
·
442 Posts
what rpm are you running when it surges because the exhaust valves open up right around 6900-7000 rpm and when they do open up, if you have ever seen a dyno, the hp #'s rise pretty quickly when the valves open.  

its possible that if your sitting right at that rpm that your valves could be opening or closing and that may be the surging that you are feeling

is the clutching stock?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Everythig is stock. I thoght the power valves also need not only RPM but at least so much throttle. I can feel when they open, if you play with it a little and I don't believe that they are ready to open.
 

·
Registered
Joined
·
2 Posts
It is the power valves, if you listen close you hear the sound of the exhaust change tone when the surging is going on. IE: the valve opening and closing.
 
0

·
Guest
Joined
·
0 Posts
I experienced this on my ZL600 SS efi at relatively the same speed as well. What is this?
 

·
Registered
Joined
·
442 Posts
the valves are electronically controlled to open at about 6950 rpm and they close at approximently 6800 rpm when they open up you should be able to hear the change in exhaust sound and the power jumps pretty quickly when they open so that could definitely be what the surging is all about if your clutching is stock then i would definitely say that is whats happening

nothing to worry about, i would start to worry if it stops doing it because that could mean that your valvesare gummed up and not opening and closing anymore
 
1 - 6 of 6 Posts
Top