Snowmobile World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
my buddy was on the road and as soon as he jumped into the snow filled ditch his sled died, upon further inspection, his primary was fully shifted out along with the secondary totally opened... ??
the all 3 Arms inside the TRA were totally off of the ramps! we had to pry on the one sheave to get the arms back onto the ramps... what would have made this happen?
we got the sled back to "normal" on the trail, got it back to my house, took the primary off, opened it and saw that the splined end had gotten to the end of the spline and spun a little, so we filed and filed to get the teeth on the spline back to normal and put the clutch back together... he drove the sled home and as far as i know it worked fine... im stumped? any ideas?
 

·
Registered
Joined
·
149 Posts
Discussion Starter #3
thats the 1st thing i thougth too was over-rev but we were only doing about 50 when it happend...i was also thinking that being fully shifted out and a hard load on the engine (deep snow) may have caused this to happen?
 

·
Registered
Joined
·
27 Posts
thats the 1st thing i thougth too was over-rev but we were only doing about 50 when it happend...i was also thinking that being fully shifted out and a hard load on the engine (deep snow) may have caused this to happen?[/b]
I cant see it being torqued down to 75-80 lb ft and the outter half slip (strip) on the fine splines,if it did thats the first Ive seen a TRA do it in 18yrs,are you sure no ones had it apart recently
 

·
Registered
Joined
·
149 Posts
Discussion Starter #5
infact now that you mention it, we did take the clutch apart just 50 mi prior, but i/we put it back to gether exactly how we took it apart, lining up all arrows and marks.. maybe the main clutch/motor bolt wasnt tight enough??
 

·
Registered
Joined
·
149 Posts
Discussion Starter #7
ok just talked to my buddy on the phone, he said that he was at WOT when he jumped into the powder... he was a little ways ahead of me so I wasnt sure just how fast he was going. but he told me his speedo read around 90 or so... if that helps?
 
1 - 7 of 7 Posts
Top