Snowmobile World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #1
Ok here's a quick run down on what I need to know about a 03 F7 snowpro. 1st some one removed the limiter strap's and cross shaft,we got new strap's and cross shaft's but whre on the front of the rail's should the limiter shaft be and then how do I set the limiter straps.....Any one have a GOOD pic of the front of the rail's showing the limiter shaft and strap's....? 2nd we took it out last night and had a problem, the oil injection line that run's behind the clutch broke. We got real lucky that the oil got on the belt and we stoped cause of the smell ,smoke and the belt noise.Now we got lucky the engine was still getting oil so were good there(this happened over like 15 seconds). Now the belt's outer case got cought behind the primary clutch. I spent 1 hour fishing the blown belt out,now I'm going to look at the crank seal with a mirror to see if it look's like it was hurt from the belt being wraped up behind the clutch. If the seal look's good or bad is there any way to tell if it's leaking now(I don't have any speical tool's to test with)I was wondering if part of the belt could have got under the seal and cut it from the inside or if there could be any other damange to the side of the engine ? 3rd................what is the RIGHT way to bleed the oilinjection pump and then to make sure the pump is working right ? PLEASE HELP,this was my friends fist ride on a sled that's cost him a lot of money to be rideable and now it's broke with less than 100 mile's this year.
 

·
Registered
Joined
·
324 Posts
#3- prop the left ski up on something and hang the back of the sled from the ceiling so you get about 3 feet of height and let it sit overnight, the air will work it's way back to the reservoir. If you are concerned about the pump working right just fill the reservoir with oil and add 300ml to the tank and take it for a good long ride, then inspect the oil used to see how it is working. The 03's were lean from factory and had a recall.

#2- the best way to tell if a crank seal is gone is by an irratic or higher than normal idle, it can also be a real pain to start. Havn't seen a seal go yet on a F cat and i have blown lots of 020 belts on my mod.

#1- you can go to Alpha Sports and look at their micro phiche under rear suspension for your model and year and be able to see where the bar and straps bolt to. Just remember the limiters are not adjustable so you might want to drill a couple of holes in them before you install.
 

·
Registered
Joined
·
204 Posts
Discussion Starter #3
#2 have you ever had a belt wrap up on the back side of the clutch and get wedged bewteen the engine plate and the engine ? Also,I don't know how his sled started before but every time he start's it now it "pops" out the exhaust and take's 2-3 pull's,it's EFI. I have a ZL 600 EFI and mine starts first pull and has never "poped" . I know there diffrent engine's but that dosn't seem right that they start that much diffrent. On #3 found the bleeder and oil injection work's fine now.
 
1 - 3 of 3 Posts
Top