Snowmobile World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,604 Posts
Discussion Starter #1
Well as you know by now the 07 Phazer has been having a overheating Problem I have read lot’s about it ours has done it twice this winter .....and totally when you would not expect it....so I have been going around the web reading on these problems...

So I called my dealer today .... I find out the mountain comes equipped with a fan but the FX & GT don’t well it looks like Yamaha thought they could save some money....the FX & GT have the bracket already mounted on the sled...

So I said what are we doing about this problem my dealer said bring your sled in Rick and we will mount it in for you.....I said at no cost to me he said that’s right no cost to you....yes all the wiring is all in place too...wow

How come you did not call me he said not all sled are having this problem....


Rick
 

·
Registered
Joined
·
361 Posts
wow, at least they are taking care of it for you. Do you think that they are putting the fan's on all the 08 models?
 

·
oldslowsledder
Joined
·
6,491 Posts
The phazers are liquid cooled, where are they installing a fan?
 

·
Registered
Joined
·
195 Posts
I knew a guy that had a Venture. I can't remember what the setup was exactly, but I know his Venture had a fan that he could turn on when he was running in low snow conditions. It wouldn't keep the sled cool for a long ride, but if he was just crossing a lake or something, he just flipped a switch and away he went.
 

·
Registered
Joined
·
2,604 Posts
Discussion Starter #5
David I will look on Friday I’m off to the show of all the sleds....

Cory right behind the radiator it’s so funny you look the mount is all in place right from the factory also the wiring too...

Ice sounds like a good set up eh...


Rick
 

·
Registered
Joined
·
2,604 Posts
Discussion Starter #6
Well I took the Phazer into the shop today here is a picture of the fan in place Cory9 it is behind the rad...
[attachment=35136:DSCF0123.JPG]


Rick
 

Attachments

·
Registered
Joined
·
4,869 Posts
Quite the oversight IMO

Nice to see you have had this resolved Rick :)
 

·
Registered
Joined
·
6 Posts
fyi
most of the overheats on the late model yammie's is due to the factory adding straight anti freeze....drain 30-40 percent and add the appropriate water and if you're on snow you wont over heat anymore !
 
1 - 8 of 8 Posts
Top