Snowmobile World banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1979 exciter 440, anyone know the settings for the screws on the carb, and how to adjust the oil pump? mine smokes like a broke chimney all the time, and i think whoever had it before me has the carb settings all out of whack. if anyone could help me out that would be great.
 

·
Premium Member
Joined
·
709 Posts
Well the first thing to do with your oil is fill the oil tank and gas tank before you ride. Then ride normally using several gallons of fuel. Then fill up the oil and gas again, measuring exactly how much you used. You will probably have to convert everything to ounces to get an accurate measurement. 32:1 is a good oil rate for that sled I'd say. If you are using a lot more oil than that, you may need to make an adjustment. Or your oiler might be broken and just dumping oil in there uncontrollably. But don't assume you're using too much oil just because it's smoky. If you cut your oil consumption when it is already where it is supposed to be you're going to kill your engine.

The only thing the carb screws do are adjust your idle speed and idle mixture. Midrange is controlled by your needle position which is adjustable when you take off the top cap, and full throttle by the main jet which has to be replaced if it's wrong. My guess is you have a different problem. It could be too much oil. It could be a stuck or improperly adjusted choke cable. I would definitely ensure that it's not the choke cable before anything else. That would be the first thing I check and very thoroughly.
 
1 - 2 of 2 Posts
Top