Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey everyone...

I have a 1979 yamaha 440 exciter.. that has always been a REALLY good running sled..

last time I rode it was about 4 years ago.. and since it sat un touched covered upnorth at the cabin..

I recently picked it up in hopes of teaching the kids to ride on the same sled I learned to (roughly 20 years ago).. but I ran into an issue..

for some reason it is not sucking ANY gas..

things ive done..

1... rebuilt the fuel pump (rebuild kit was a bit diffrent as far as marterials used.. Im guessing what I changed out was origional)..
if anyone has a diagram of this Id like to see just to make sure its together corrently..

2... replaced crank vacumme line.. (however, I am not getting a suction out of this line.. it actually is blowing air out of it??? is that correct?? ive always though it would suck in air not blow out)

3... totaly cleaned carb removed all jets and bowl and all that and cleaned well..


the sled will run like a top if I spray gas into the carb (I put some gas In a spray bottle thinking maybe I could prime the fuel pump since it was totaly dry from being rebuilt.. but no luck)..
but yea the sled runs great.. just will not suck gas at all..

any help would be AWSOME!!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
opps I accidently put this in the wrong spot.. can mods please delete?

I will post in the proper section..
 

·
Registered
Joined
·
33 Posts
did you check the gas line coming from the tank? i had the same problem before, i checked the line and the was a small hole in the line and was drawing air and would not start.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
did you check the gas line coming from the tank? i had the same problem before, i checked the line and the was a small hole in the line and was drawing air and would not start.

Yea I replaced all the lines with new fuel line.. (the clean blue looking stuff)..

I will check it out again tonight when I get home.. just to double check make sure I didnt tear it or something when putting it on or off.. (since I have a few times now while working on it..)

But yea there all brand new..
 
1 - 4 of 4 Posts
Top