Snowmobile World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've got a 1980 JD Liquifier that runs good for 5 to 10 minutes then It acts like it loads up on the mag side cylinder I've tried smaller pilot jets. It almost seems like when the motor gets good and hot it don't wanna run. I hope somebody here can help figure this out. thanks Bryan
 

·
Registered
Joined
·
30 Posts
While it's cold , you wont notice any extra choke....fuel pump can be burst
and sucking in impulse line ...BUT last fall I had one doing the same thing
and it was the tiny orings that seal the fuel bowls to the centre post of the
carb....instead of sucking the fuel in the jet (in bowl) it was drawing high
speed fuel around the stem and over fueling ....I tried everything else first
and this was the problem ....a dollars worth of oring made it into a
rocket ship on sod .
RON
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the advise but I have already replaced those o-rings last week. I can't figure out what to do next. Bryan
 

·
Registered
Joined
·
30 Posts
Darn !!!!! I was really hoping .....I tried running a diff fuel pump first , then used
a clear fuel line in pulse connection to watch for fuel there...seem to drizzle a small
amout all the time ,,,seemed normal ,,,,,The oil injection pumps different amounts of
oil to the 3 spots...I think the centre brg is more than the outside and I don't know
where the spent oil gets into the crankcase .....
Maybe switch carb positions ......???
Mark any parts orig postions before mixing around ...helps later ....
If the belt is worn on an 80 , You need to remove shims on secondary to
tighten it up again ...otherwise they bog and puke and never quite hit enough
RPM to pull away ...Some Liquifire's were more tolerant than others ......
There are a few guys vintage racing them on www.acscc.com site .
MrMotoSki (Richard) and "That girl racing " (Peter)...
Maybe sign on ang give them a shout ??
Good Luck
RON
 

·
Registered
Joined
·
30 Posts
Take muffler off and hook to a shop vac and make sure it is
free off debris , such as a mouse nest in the tail pipe , or if
you had the pipe off something may have crawled in .
Vac should not rev up (like when covered)
RON
 
1 - 5 of 5 Posts
Top