Snowmobile World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 94 storm that works perfect however about once in every 50 miles it will just shut down when I am stopped and the engine is at good idle. It reacts as if I have hit the kill switch, in fact the first time this happened I figured I hit the kill switch by accident, untill it happened continiously. It has only happened at a stop when the engine is at an idle,(it is around 1600rpm) and never when the machine has been in motion.
The engine is tuned perfect, good idle, spark etc.
I do not know what would cause this, should I look at some electrical connections?
Any advice?
Thank You
Thank you
 

·
Registered
Joined
·
16 Posts
Well my guess is that your throttle cable ha streched a little and is activating the saftey cutoff switch , its a little pin switch behind the throttle lever , on the throttle assembly . What you have to do is adjust the throtle cables by turning the adjuster nuts on the tops of the carbs . Just make sure you do the same to all the carbs , also you shouldnt have to go out that far so do a little then try it out and see . If you go to far you might un sync your carbs ....
 

·
Registered
Joined
·
40 Posts
HAD THE SAME PROBLEM WITH MY 1993 XLT!
IT WAS THE LITTLE PIN BEHIND THE THROTLE LEVER!!  I HAD JUST PUT A NEW THROTLE LEVER ON AND THUS NEEDED TO ADJUST THE CABLES, THEN I HAD TO TURN THE IDLE SCREWS OUT SLIGHTLY AFTER, TO RETAIN THE PROPER IDLE RPM!

GOOD LUCK
 
1 - 7 of 7 Posts
Top