Snowmobile World banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, My son and I purchased a 1997 XCR 600. Starts first pull every time but smokes a lot; white smoke even after warm.. Compression is 90, 85 ,90. We checked the oil pump and the return spring is working properly so it is not stuck wide open. We noticed the coolant was on low side in the reservoir when we bought it. Wondering if there is a slight head gasket leak possible causing the lower compression? What would you recommend I try first. New head gaskets?
 

·
Super Moderator
Joined
·
15 Posts
Sounds like low compression to me. Try a different known good tester. Yes, coolant leak will need a head gasket and I'd check for warpage of the head as well. These engines while good are now older and have problems. I would check crank runout and phasing. A complete rebuild of a three cylinder is expensive. You could be heading in that direction.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Sounds like low compression to me. Try a different known good tester. Yes, coolant leak will need a head gasket and I'd check for warpage of the head as well. These engines while good are now older and have problems. I would check crank runout and phasing. A complete rebuild of a three cylinder is expensive. You could be heading in that direction.
When I get the head off, if it is in fact a bad head gasket, I'm assuming that would drop the compression? Good point, will check the head for warpage. I'm hoping to just freshen up the top end and then go from there.
 
1 - 4 of 4 Posts
Top