Snowmobile World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
ok i just installed boysen reeds and a boost bottle and the idle is way too fast...........it runns at 3000+ rpms at idle......i tried adjusting the air screw and that did nothing so i adjusted the idle screw and that did nothing..........so i raised the pilot from a 40 to a 48 and it only lowered it like 200rpm....!!!!!!!!!! i cant figure out what to do and it is getting close to winter! but i did drive it on the grass this way and it seems to run great through the power band so it is kind of funny.........i dont think it would have any; air leaks anywhere cus i looked at the boots and such and they looked fine.............DOES ANYONE HAVE ANY IDEAS ON WHAT IS WRONG???????????????????????????????????????
 

·
Registered
Joined
·
791 Posts
Well first off does your sled have flatslide carbs? If it does you were turning the fuel screw they don't have air screws. Also maybe you kinked the throttle cable when you installed the mods and now the slides don't go down in the carbs enough. How does it start?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
well no they are not flat slides they are d slides the screw is on the air box side so it is for air (im pretty sure) and i disconected the slides from the cables and still nothing....................good suggestion but tryed it.... any other ideas that could help me?????????????????????? oh yeah it starts real good could it be the stupid accs
 

·
Registered
Joined
·
90 Posts
if you are not getting any adjustment out of your air screws, you are still way to lean on the pilot jets,keep going up on your pilots until the rpms drop and it idles good. then try to adjust your air screws. this should work fine, the boost bottle combined with the reeds had to increase your air flow dramaticly to cause this much of a differance. ;)
 

·
Registered
Joined
·
791 Posts
Yeap they are air screws then. I would try the pilots I guess. But not sure what else to try. Are the carbs clean and in sync.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
well i jumped from a size 40 to a 58 pilot jet and now it idles at 1500 rpm but when you first start it it idles at about 2500 but it drops off after a min of idle when it warms up some...........is jumping that many jets normal when adding a boost bottle and reeds??????
 

·
Registered
Joined
·
52 Posts
If your cables are not kinked, you proberly have an air leak in the carb boots, spray carb clean on your carb boots and your boost bottle when the motor starts to cut out that is where your leak is.
 
1 - 7 of 7 Posts
Top