Snowmobile World banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm new to snowmobiling, and got a 2001 RMK 700 144 (3600 miles) from a good friend of mine that got me into this sport, and he has taken quite good care of it over the years.
Everything works great (carbs were cleaned yearly, clutch belt is newer (2017), fuel drained after every season, proper Polaris oil, track lifted from ground during storage, fresh grease every season, spark plugs cleaned or replaced,, etc.).
I did have to install a new TPS and a few other lines due to rats/ mice chewing through them, also a new fuel line bung cause the old one rooted away....but no main issues after replacing. Turned over after 10 pulls after these fixes. It does run, and man, does it just wanna go fast.

My issue is the Brake Light on the console and the tail Brake Light are always on.... like I said, the Sled runs and the brakes do work (so not a constant Brake is engaged situation since we did ride the other weekend for about a 30 mile loop and no problem other than both lights constantly on). Both are just always lit.

Before I start opening up everything on the console to check the lines and connectivity, and removing the seat to expose the wiring to the tail Brake Light, could there be another spot in missing to figure out why they are always on?

Any suggestions will help. Thanks.
 

·
Registered
Joined
·
105 Posts
brake light is stuck ,or the wires to it are shorted, switch will either be in brake control lever area , or a switch in the hydraulic line going to the caliper, looks like a oil pressure switch for a auto, determine what set up you have, disconnect to see if lights go out , if they are still on ,switch probably good , what is common to happen wires get rubbed thru under the seat and short out , good luck
 
1 - 2 of 2 Posts
Top